<!DOCTYPE html>
<html lang="en" dir="ltr" data-locale="US" class="">
<head>
<meta charset="utf-8">
<script>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</script>
<link rel="alternate" hreflang="x-default" href="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<link rel="alternate" hreflang="en-US" href="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<link rel="alternate" hreflang="en-GB" href="https://www.laptopmag.com/uk/reviews/ipad-pro-2021-129-inch-review">
<link rel="alternate" hreflang="en-AU" href="https://www.laptopmag.com/au/reviews/ipad-pro-2021-129-inch-review">
<link rel="alternate" hreflang="en-NZ" href="https://www.laptopmag.com/au/reviews/ipad-pro-2021-129-inch-review">
<link rel="amphtml" href="https://www.laptopmag.com/amp/reviews/ipad-pro-2021-129-inch-review">
<script>
window.vanilla = window.vanilla || {};
window.VAN = window.VAN || {};
// For AB testing
// We should come up with a list of feature flags
var defaultFlags = {"jsCookie":{"enabled":true},"navSubscribe":{"enabled":true},"suggestionBox":{"enabled":true},"regionDropdown":{"enabled":true},"regionRedirect":{"enabled":true},"reviewSpecBox":{"enabled":true},"jwplayer":{"carousel":{"enabled":true,"IDs":{"playerID":"JEMVeU93","searchPlaylistID":"MOUpR89J","divID":"botr_MOUpR89J_JEMVeU93_div","fallbackPlaylistID":"MOUpR89J","fallbackDivID":"botr_MOUpR89J_JEMVeU93_div","key":"NLVTwYKe5kBs2O1ZEZFGvVo1Y44MJtPAymTh\/PhEGb7r7GUh","tintLogo":true,"useSearchPlaylist":false}}},"parsely":{"enabled":true},"onesignal":{"enabled":true},"gtm":{"vanilla":true,"sitespecific":true},"selligent":{"enabled":false},"raygun":{"enabled":false,"rum":false,"crashReporting":false},"thatswhy":{"enabled":false}};
window.vanilla.featureFlags = Object.assign({}, defaultFlags, window.vanilla.featureFlags || {})
window.vanilla.resourceBasePath = '//vanilla.futurecdn.net/laptopmag/media/shared/js/';
window.vanilla.addScript = function(src, id) {
var script = window.document.createElement('script');
script.src = src;
script.async = true;
script.id = id;
window.document.head.appendChild(script);
}; </script>
<style id="vanilla-slice-root">
:root{ --affiliate-disclaimer-margin: 0;--affiliate-disclaimer-padding: 30px 24px 10px 24px;--affiliate-disclaimer-font-color: #333;--locale-selector-trigger-text-color: #333; }
</style>
<style id="vanilla-slice-combined-css">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</style>
<script>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</script>
<!-- Hawk Elements -->
<style id="hawkStyles">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</style>
<link rel="preload" href="https://hawk.laptopmag.com/css/browser/16.2.5-4125c45102f18311486bcba061cb8d43aa437e0a/review.min.css" as="style" onload="this.rel = 'stylesheet'"><link rel="preload" href="https://hawk.laptopmag.com/css/browser/16.2.5-4125c45102f18311486bcba061cb8d43aa437e0a/alpine.min.css" as="style" onload="this.rel = 'stylesheet'"><link rel="preload" href="https://hawk.laptopmag.com/css/browser/16.2.5-4125c45102f18311486bcba061cb8d43aa437e0a/inbody.min.css" as="style" onload="this.rel = 'stylesheet'"><link rel="preload" href="https://hawk.laptopmag.com/css/browser/16.2.5-4125c45102f18311486bcba061cb8d43aa437e0a/seasonal.min.css" as="style" onload="this.rel = 'stylesheet'"><link rel="preload" href="https://hawk.laptopmag.com/css/browser/16.2.5-4125c45102f18311486bcba061cb8d43aa437e0a/promotion.min.css" as="style" onload="this.rel = 'stylesheet'"><link rel="preload" href="https://hawk.laptopmag.com/css/browser/ltm.min.css" as="style" onload="this.rel = 'stylesheet'">
<!-- End Hawk Elements -->
<script type="module" id="hawk-script-es6" async src="https://hawk.laptopmag.com/js/w/es6/responsive.js"></script>
<script>
window.hawk_widgets_endpoint = "https://hawk.laptopmag.com";
window.hawklinks_endpoint = "https://hawk.laptopmag.com";
window.hawk_api_endpoint = "https://hawk.laptopmag.com";
</script>
<script type="nomodule" id="hawk-script" async src="https://hawk.laptopmag.com/js/w/es5/responsive.js"></script>
<script>
window.adParameters = window.adParameters || {
site: 'laptopmag',
content: 'unknown',
type: 'review',
};
</script>
<style>
@font-face {
font-family: "Open Sans";
font-weight: 400;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans.woff") format("woff"),
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans.ttf") format("ttf");
font-display: swap;
}
@font-face {
font-family: "Open Sans";
font-weight: 600;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Semibold.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Semibold.woff") format("woff"),
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Semibold.ttf") format("ttf");
font-display: swap;
}
@font-face {
font-family: "Open Sans";
font-weight: 700;
font-style: normal;
src:
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Bold.woff2") format("woff2"),
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Bold.woff") format("woff"),
url("https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Bold.ttf") format("ttf");
font-display: swap;
}
html {
font-family: 'Open Sans';
}
</style>
<style>
head.icon-invisible ~ body .icon, head.icon-invisible ~ body .list-title::before {
visibility: hidden !important;
}
</style>
<script>
var head = document.getElementsByTagName("head")[0];
if ("fonts" in document) {
head.classList.add('icon-invisible')
var font = new FontFace(
'laptopmag',
'url(https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/laptopmag.woff), url(https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/laptopmag.ttf), url(https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/laptopmag.eot), url(https://vanilla.futurecdn.net/laptopmag/296797/media/fonts/laptopmag.svg) ', {
display: 'swap'
}
)
performance.mark("font load start")
font.load().then((fontFace) => {
document.fonts.add(fontFace)
performance.mark("font load finish")
performance.measure("font load time", "font load start", "font load finish")
head.classList.remove('icon-invisible')
console.log(fontFace.family, 'loaded successfully.')
}, (fontFace) => {
console.error('Current status', font.status);
});
}
</script>
<script>window.gaCookieSet=/(?:^|;\\s*)_ga/.test(document.cookie);</script>
<script>'use strict';(function(){function g(c,a){return function(){return setTimeout(c,a)}}function h(c,a,b){b=void 0===b?function(){}:b;return function(){var d=c.createElement("script"),e=c.getElementsByTagName("script")[0],f=k({},a,{async:1});Object.keys(f).forEach(function(a){return d.setAttribute(a,f[a])});e.parentNode.insertBefore(d,e);b()}}var k=Object.assign||function(c){for(var a=1;a<arguments.length;a++){var b=arguments[a],d;for(d in b)Object.prototype.hasOwnProperty.call(b,d)&&(c[d]=b[d])}return c};
window.vanilla.addJs=function(c,a,b,d){b=void 0===b?!1:b;c=h(document,c,d);a=null!==a?g(c,a):c;b?window.reliablePageLoad.then(a):a()}})();</script>
<script>'use strict';(function(){function f(a,d){return function(){var c=a.createElement("link"),b=g({},d,{rel:"stylesheet",type:"text/css"});Object.keys(b).forEach(function(a){return c.setAttribute(a,b[a])});var e=a.getElementsByTagName("head")[0];e.parentNode.insertBefore(c,e)}}var g=Object.assign||function(a){for(var d=1;d<arguments.length;d++){var c=arguments[d],b;for(b in c)Object.prototype.hasOwnProperty.call(c,b)&&(a[b]=c[b])}return a},h=window.requestAnimationFrame||window.webkitRequestAnimationFrame||
window.mozRequestAnimationFrame||window.msRequestAnimationFrame||function(a){return window.reliablePageLoad.then(a)};window.vanilla.addCss=function(a){return h(f(document,a))}})();</script>
<script>
window.bordeaux = window.bordeaux || {};
window.bordeaux.cmd = window.bordeaux.cmd || [];
window.bordeaux.cmd.push(function(){
if (window.disableBordeaux === true) {
return;
}
if (window.dfp_config) {
window.bordeaux.setTargeting({
source: window.dfp_config.source || '',
kw: window.dfp_config.keywords.split(','),
vertical: window.dfp_config.vertical.split(','),
pagetype: (window.dfp_config.page_type || '').replace(',', '-'),
manu: window.dfp_config.product_brand,
articleid: window.dfp_config.article_id,
sitePlatform: window.dfp_config.site_platform,
});
window.bordeaux.setPageCategory(window.dfp_config.page_type);
}
if (window.FEPProcess) {
var fep = window.FEPProcess(window.FEP_object);
window.resolveFEP(fep);
window.bordeaux.setTargeting(window.FEPSanitise({
fepPrimaryProduct: fep.primaryProduct,
fepSecondaryProducts: fep.secondaryProducts,
fepCompanies: fep.companies,
fepCategory: fep.category,
fepGroups: fep.groups,
fepPrimaryCompany: fep.primaryCompany,
primaryCategory: fep.primaryCategory,
secondaryCategories: fep.secondaryCategories,
tertiaryCategories: fep.tertiaryCategories,
}));
}
window.bordeaux.setPageTemplate("article");
window.bordeaux.init();
window.bordeaux.hybridId.then((id) => {
if(!window.ga) { return }
window.ga('send', 'event', 'future_id', 'set hybrid_id', '', Object.assign({}, window.analytics_ga_data, { dimension77: id, nonInteraction: true }));
});
});
</script>
<script defer src="https://bordeaux.futurecdn.net/bordeaux.js" onerror="handleHeaderError()" crossorigin="anonymous"></script>
<!-- tag factory //-->
<link rel="preload" as="font" href="//vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="dns-prefetch" href="//cdn.mos.cms.futurecdn.net">
<link rel="dns-prefetch" href="//vanilla.futurecdn.net">
<link rel="dns-prefetch" href="//widgets.hawk-assets.co.uk">
<link rel="dns-prefetch" href="//www.google-analytics.com">
<link rel="dns-prefetch" href="//cdn.onesignal.com">
<link rel="dns-prefetch" href="//cdn.parsley.com">
<link rel="dns-prefetch" href="//cdn.jwplayer.com">
<link rel="dns-prefetch" href="//cdn.adsafeprotected.com">
<link rel="dns-prefetch" href="//securepubads.g.doubleclick.net">
<link rel="dns-prefetch" href="//quantcast.mgr.consensu.org">
<link rel="dns-prefetch" href="//vendorlist.consensu.org">
<link rel="dns-prefetch" href="//sb.scorecardresearch.com">
<link rel="dns-prefetch" href="//js-sec.indexww.com">
<link rel="dns-prefetch" href="//c.amazon-adsystem.com">
<link rel="dns-prefetch" href="//ads.servebom.com">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Semibold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/laptopmag/296797/media/fonts/OpenSans-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="//vanilla.futurecdn.net/laptopmag/296797/media/fonts/laptopmag.woff" type="font/woff" crossorigin="anonymous">
<meta data-static-host="//vanilla.futurecdn.net/laptopmag/296797" id="static-host-pattern">
<link rel="preload" as="style" href="//vanilla.futurecdn.net/laptopmag/296797/media/css/laptopmag.min.css">
<link rel="preload" as="script" href="//vanilla.futurecdn.net/laptopmag/296797/media/shared/js/main.9b28108de37dacd40e1f.bundle.js">
<link rel="preload" as="image" href="//vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg">
<meta name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1">
<title>iPad Pro 2021 (12.9-inch) review | Laptop Mag</title>
<meta name="pub_date" content="2021-06-15T22:00:49+00:00">
<meta name="description" content="The iPad Pro 2021 (12.9-inch) is the most advanced tablet ever although the new upgrades aren't always noticeable ">
<link rel="canonical" href="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<style id="critical-styles">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</style>
<link rel="apple-touch-icon" href="https://vanilla.futurecdn.net/laptopmag/296797/apple-touch-icon.png">
<link rel="shortcut icon" href="https://vanilla.futurecdn.net/laptopmag/296797/favicon.ico" sizes="16x16">
<link rel="shortcut icon" href="https://vanilla.futurecdn.net/laptopmag/296797/apple-touch-icon.png" size="120x120">
<meta name="msapplication-TileColor" content="#000000">
<meta name="msapplication-TileImage" content="https://vanilla.futurecdn.net/laptopmag/296797/apple-touch-icon.png">
<meta property="og:title" content="iPad Pro 2021 (12.9-inch) review">
<meta property="og:site_name" content="LaptopMag">
<meta property="og:url" content="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<meta property="og:description" content="The iPad Pro 2021 (12.9-inch) is the most advanced tablet ever although the new upgrades aren't always noticeable ">
<meta property="og:image" content="https://cdn.mos.cms.futurecdn.net/DrnTnHoDLZHuD5sZMovj2i-1200-80.jpg">
<meta property="og:image:width" content="1200">
<meta property="og:type" content="article">
<meta property="article:publisher" content="https://www.facebook.com/laptopmag">
<meta property="article:author" content="https://www.facebook.com/laptopmag">
<meta property="fb:app_id" content="">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@laptopmag">
<meta property="twitter:title" content="iPad Pro 2021 (12.9-inch) review">
<meta property="twitter:description" content="The iPad Pro 2021 (12.9-inch) is the most advanced tablet ever although the new upgrades aren't always noticeable ">
<meta property="twitter:creator" content="@laptopmag">
<meta property="twitter:image" content="https://cdn.mos.cms.futurecdn.net/DrnTnHoDLZHuD5sZMovj2i-1200-80.jpg">
<meta property="twitter:account_id" content="9696142">
<meta name="google-site-verification" content="NICBSFagu-bIel2Q6NJzRhCnej-IXX3HTecmDGrHkEg">
<meta name="taboola:url" content="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<meta name="botify-site-verification" content="mv6X9l0gkc03wTqUa6WuwxNmgBQdnRY4">
<meta name="theme-color" content="#6772e4">
<script type="text/javascript">
window.missingImage = function(){var missingImage = document.createElement('img');missingImage.src = '//vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg';return missingImage;}
var FEP_object;
var getConnectionDimensions=function(e){var n=navigator.connection||navigator.mozConnection||navigator.webkitConnection;return void 0!==n&&(e.dimension31=n.downlink,e.dimension30=n.effectiveType),e},getConnectUserDimensions={isAuthenticated:function(){var e="false",n=localStorage.getItem("connectUser");if(console.log("GA getUserDimensions",n,localStorage.getItem("connectUser")),n){n=JSON.parse(n);var i=new Date(n.exp).getTime(),t=(new Date).getTime();i>t&&(e="true")}return e}};VAN.gaDimensions=function(e,n,i,t){ga("create",e,"auto",{useAmpClientId:!0,allowLinker:!0}),n=getConnectionDimensions(n),null!=i&&ga("set",{dimension57:i}),ga("require","displayfeatures"),t.fepPrimaryProduct&&ga("set",{dimension40:t.fepPrimaryProduct}),t.fepSecondaryProducts.length&&ga("set",{dimension41:t.fepSecondaryProducts.join("|")}),t.fepPrimaryProduct[0]&&ga("set",{dimension42:t.fepPrimaryCompany}),t.fepCompanies.length>=1&&ga("set",{dimension43:t.fepCompanies.join("|")}),t.fepPrimaryProduct&&ga("set",{dimension45:t.fepPrimaryProduct}),t.fepCategory&&ga("set",{dimension46:t.fepCategory}),t.fepArticleName.length>0&&ga("set",{dimension47:t.fepArticleName}),t.fepAlgorithm&&ga("set",{dimension50:t.fepAlgorithm}),t.fepNullified?ga("set",{dimension51:"true"}):ga("set",{dimension51:"false"}),"object"==typeof t.fepGroups&&Array.isArray(t.fepGroups)&&ga("set",{dimension58:t.fepGroups.join("|")}),t.thirdCategories&&ga("set",{dimension74:t.thirdCategories.join("|")}),ga("set",{dimension13:getConnectUserDimensions.isAuthenticated(),dimension10:document.querySelector("html").getAttribute("data-locale").replace("_","-")});try{var o=document.cookie.replace(/(?:(?:^|.*;\s*)_ga\s*\=\s*([^;]*).*$)|^.*$/,"$1");o&&ga("set",{dimension59:o})}catch(r){console.log("GA ID error: ",r)}ga("require","linker"),ga("send","pageview",n)}; VAN.assignFep=function(a){try{var e=e||{fepPrimaryProduct:"",fepSecondaryProducts:Array(),fepCompanies:Array(),fepHawk:{},fepCategory:"",fepGroups:Array(),kwMunge:Array(),fepArticleName:"",fepPrimaryCompany:"",fepAlgorithm:"",fepNullified:"",ready:!1,primaryCategory:"",secondaryCategories:Array(),thirdCategories:Array()};if(window.FEP=e,!e.ready){if("undefined"==typeof a)throw"FEPNotReady";e.fepPrimaryProduct=a[0].adTags.primaryProduct,e.fepSecondaryProducts=a[0].adTags.secondaryProducts,e.fepCompanies=a[0].adTags.companies,e.fepCategory="object"==typeof a[0].adTags.category?"":a[0].adTags.category,e.fepGroups="undefined"!=typeof a[0].adTags.groups?a[0].adTags.groups:Array(),e.fepArticleName=a[0].articleName,e.fepAlgorithm=a[0].strategy,e.fepNullified=a[0].nullified,e.fepPrimaryCompany=null!==a[0].adTags.primaryCompany&&a[0].adTags.primaryCompany.length>=1?a[0].adTags.primaryCompany:" ","undefined"!=typeof a[0].adTags.primaryCategory&&"undefined"!=typeof a[0].adTags.secondaryCategories&&"undefined"!=typeof a[0].adTags.thirdCategories&&(e.primaryCategory=a[0].adTags.primaryCategory,e.secondaryCategories=a[0].adTags.secondaryCategories,e.thirdCategories=a[0].adTags.thirdCategories),e.fepIAB=[],e.ready=!0;var r=["fepPrimaryProduct","fepSecondaryProducts","fepCompanies","fepCategory"];r.forEach(function(a){var r=e[a];"object"==typeof r&&(r=r),e.kwMunge=e.kwMunge.concat(r)}),e.kwMunge=e.kwMunge.filter(function(a,r){return e.kwMunge.indexOf(a)==r}),"undefined"!=typeof a[0].hawkTags.primaryProduct&&(e.fepHawk.primaryProduct=a[0].hawkTags.primaryProduct),"undefined"!=typeof a[0].hawkTags.secondaryProducts&&(e.fepHawk.secondaryProducts=a[0].hawkTags.secondaryProducts),"undefined"!=typeof a[0].hawkTags.companies&&(e.fepHawk.companies=a[0].hawkTags.companies),"undefined"!=typeof a[0].hawkTags.groups&&(e.fepHawk.groups=a[0].hawkTags.groups),"undefined"!=typeof a[0].hawkTags.category&&(e.fepHawk.category=a[0].hawkTags.category)}return window.FEP=e,e}catch(o){console.log("fep ga exc "+o.message)}};;
</script>
<script>
try{
var FEP_object = [{"acceptableLanguage":true,"adTags":{"category":"ipad_pro_12.9-inch","companies":["Verizon_Wireless","Adobe_Inc.","Samsung","Qualcomm_Snapdragon"],"editorProducts":"iPad_Pro_2021","groups":["ipad_pro_12.9-inch","iPad_Pro","Apple","Tablets"],"primaryCategory":"ipad_pro_12.9-inch","primaryCompany":"Apple_Inc.","primaryProduct":"iPad_Pro_2021","secondaryCategories":["ipad_pro_12.9-inch","iPad_Pro","Apple","Tablets"],"secondaryCompanies":["Verizon_Wireless","Adobe_Inc.","Samsung","Qualcomm_Snapdragon"],"secondaryProducts":["IPad_Pro","IPad","IPadOS","IPad_Air","Tablet_computer"],"thirdCategories":[]},"articleName":"iPad_Pro_2021_12.9-inch","articleType":"review","dataSource":"provided","hawkTags":{"primaryProduct":"iPad_Pro_2021","secondaryProducts":["IPad_Pro","IPad","IPadOS","IPad_Air","Tablet_computer"],"companies":["Apple_Inc.","Verizon_Wireless","Adobe_Inc.","Samsung","Qualcomm_Snapdragon"],"category":"ipad_pro_12.9-inch","groups":["ipad_pro_12.9-inch","iPad_Pro","Apple","Tablets"],"editorProducts":"iPad_Pro_2021","internalProductName":"iPad_Pro_2021"},"internalProductName":"iPad_Pro_2021","nullified":false,"origSite":"laptopmag","overrides":[],"rampTags":{"primaryProduct":"iPad Pro 2021","secondaryProducts":["IPad Pro","IPad","IPadOS","IPad Air","Tablet computer"],"companies":["Apple Inc.","Verizon Wireless","Adobe Inc.","Samsung","Qualcomm Snapdragon"],"category":"ipad pro 12.9-inch","groups":["ipad pro 12.9-inch","iPad Pro","Apple","Tablets"],"editorProducts":"iPad Pro 2021"},"site":"laptopmag","strategy":"6.5","timestamp":1623794457,"topProductVsproductName":"1"}];
}catch(ex){
if (typeof console == "object") {
console.log(ex);
}
}
</script>
<meta name="robots" content="max-image-preview:large">
<!-- GA TPL PREMIUM -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
// Setup the FEP global object form the FEP_object
// @TODO - can the format of FEP_object be changed server side?
VAN.assignFep(FEP_object);
var ga_code = 'UA-72111741-6';
var analytics_ga_data = {"dimension1":"review","dimension2":"","dimension3":"tablets|ipad-pro","dimension4":"Laptop_Mag\/","dimension5":"H98JCEZtvf3Udyt82RtYNG","dimension6":"|ipad_pro_12.9-inch|ipad_pro|apple|ipad_pro_2021|type_review|channel_tablets|awardeditorschoice|serversidehawk","dimension7":"phillip_tracy","dimension8":"15-06-2021","dimension10":"EN-US","dimension27":"296797","dimension33":"embed,embed,boxout,text,list,text,embed,embed,text,heading,text,heading,text,image,text,text,image,text,heading,text,image,text,heading,text,image,text,image,text,image,text,image,text,heading,text,image,text,image,text,heading,text,image,text,image,text,text,heading,text,image,text,heading,text,image,text,heading,text,heading,text,image,text,heading,text,heading,text,image,text,image,text,image,text,image,text,text,heading,text,image,text,embed","dimension95":"review","dimension106":"0","dimension126":"en","dimension127":"GB|US|AU|SG","dimension128":"15-06-2021"};
var version = 'null';
// Make sure all the GA dimensions are setup and correct
VAN.gaDimensions(ga_code, analytics_ga_data, version, window.FEP);
</script>
<!-- END GA PREMIUM -->
<script type="text/javascript">
/* <![CDATA[ */
(function() {
window.dm = window.dm ||{ AjaxData:[]};
window.dm.AjaxEvent = function(et, d, ssid, ad){
dm.AjaxData.push({ et: et,d: d,ssid: ssid,ad: ad});
window.DotMetricsObj && DotMetricsObj.onAjaxDataUpdate();
};
var d = document,
h = d.getElementsByTagName('head')[0],
s = d.createElement('script');
s.type = 'text/javascript';
s.async = true;
s.src = 'https://uk-script.dotmetrics.net/door.js?d=' + document.location.host + '&t=lapm'; h.appendChild(s);
} ());
/* ]]> */
</script>
<script>
var trailingSlash = false;
</script>
<meta name="parsely-type" content="post">
<meta name="parsely-post-id" content="H98JCEZtvf3Udyt82RtYNG">
<meta name="parsely-pub-date" content="2021-06-15T22:00:49Z">
<meta name="parsely-title" content="iPad Pro 2021 (12.9-inch) review">
<meta name="parsely-link" content="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<meta name="parsely-image-url" content="https://cdn.mos.cms.futurecdn.net/DrnTnHoDLZHuD5sZMovj2i.jpg">
<meta name="parsely-section" content="Tablets">
<meta name="parsely-tags" content="Category: Tablets,Category: iPad Pro,Category: Review,ipad pro 12.9-inch,iPad Pro,Apple,iPad Pro (2021),type_review,channel_tablets,awardeditorschoice,serversidehawk">
<meta name="parsely-author" content="Phillip Tracy">
<script type="application/ld+json">
{
"@type": "Product",
"name": "iPad Pro (2021)",
"image": {
"@type": "ImageObject",
"url": "https://cdn.mos.cms.futurecdn.net/DrnTnHoDLZHuD5sZMovj2i.jpg",
"caption": "iPad Pro 2021 (12.9-inch)",
"height": "689",
"width": "1225"
},
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review"
},
"url": "https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review",
"brand": {
"@type": "Brand"
},
"review": {
"@type": "Review",
"name": "iPad Pro 2021 (12.9-inch) review",
"reviewBody": "Today's best Apple iPad Pro 12.9 (2021) deals Apple iPad Pro 12.9 (2021) (128GB Amazon Prime $1,099 Apple iPad Pro 12.9 (2021) BHPhoto $1,099 Apple iPad Pro 12.9 (2021) Best Buy $1,099.99 Apple iPad Pro 12.9 (2021) (128GB) AT&T $1,299.99 Show More Deals We check over 250 million products every day for the best prices iPad Pro 2021 (12.9 inch) specs Price: $1,099 (starting) …",
"headline": "iPad Pro 2021 (12.9-inch) review",
"alternativeHeadline": "The iPad Pro 2021 (12.9-inch) is the most advanced tablet ever although the new upgrades aren't always noticeable ",
"datePublished": "2021-06-15T22:00:49Z",
"keywords": [
"Category: Tablets",
"Category: iPad Pro",
"Category: Review",
"ipad pro 12.9-inch",
"iPad Pro",
"Apple",
"type_review",
"channel_tablets",
"awardeditorschoice",
"serversidehawk"
],
"thumbnailUrl": "https://cdn.mos.cms.futurecdn.net/DrnTnHoDLZHuD5sZMovj2i-320-80.jpg",
"creator": {
"@type": "Person",
"name": "Phillip Tracy"
},
"publisher": {
"@type": "Organization",
"name": "Laptop Mag",
"url": "https://www.laptopmag.com",
"logo": {
"@type": "ImageObject",
"url": "https://vanilla.futurecdn.net/laptopmag/media/img/laptopmag_logo.svg",
"caption": "Laptop Mag logo"
}
},
"author": {
"@type": "Person",
"name": "Phillip Tracy"
},
"reviewRating": {
"@type": "Rating",
"ratingValue": "4.5",
"worstRating": "0",
"bestRating": "5"
}
},
"description": "The iPad Pro 2021 (12.9-inch) is the most advanced tablet ever although the new upgrades aren't always noticeable ",
"@context": "http://schema.org"
}
</script>
</head>
<body class="limit-width sticky-navigation">
<script>window.isIE = false</script>
<!--[IE]><script>window.isIE = true</script><![endif]-->
<script>
window.amIIE = function() {
return navigator.userAgent.indexOf('MSIE') !== -1 || navigator.appVersion.indexOf('Trident/') !== -1 || window.isIE;
}
</script>
<a href="#main" class="skip-to-main-content" style="position:absolute;">Skip to main content</a>
<!-- contentType : //-->
<nav class="primary-nav">
<input type="radio" name="burgerbar-expand" class="burgerbar-none-radio" id="burgerbar-none" checked>
<input type="radio" name="burgerbar-expand" class="burgerbar-radio" id="burgerbar">
<div class="burgerbar ">
<div class="container full burgerbar-small">
<label class="button-menu unchecked menu-hamburger" for="burgerbar" onclick></label>
<label class="button-menu checked menu-hamburger" for="burgerbar-none" onclick></label>
<script type="application/ld+json">
[
{
"@type": "Organization",
"name": "Laptop Mag",
"url": "https://www.laptopmag.com",
"logo": {
"@type": "ImageObject",
"url": "https://vanilla.futurecdn.net/laptopmag/media/img/laptopmag_logo.svg",
"caption": "Laptop Mag logo"
},
"@context": "http://schema.org"
},
{
"@type": "WebSite",
"name": "Laptop Mag",
"url": "https://www.laptopmag.com",
"potentialAction": {
"@type": "SearchAction",
"target": "https://www.laptopmag.com/search?searchTerm={query}",
"query-input": "required name=query"
},
"@context": "http://schema.org"
}
]
</script>
<div class="logo" id="publisherDetails">
<a href="https://www.laptopmag.com/">
<span class="site-logo">
<svg xmlns="http://www.w3.org/2000/svg" width="106px" height="27px" viewbox="0 0 392 100"><path d="M41.25 65.625H17.187v-62.5A3.126 3.126 0 0 0 14.063 0H2.816A2.814 2.814 0 0 0 0 2.813v75c0 1.55 1.26 2.812 2.815 2.812h38.122a2.814 2.814 0 0 0 2.813-2.813v-9.374a2.405 2.405 0 0 0-2.5-2.813M190 24.063a26.697 26.697 0 0 0-10.313-7.188 31.301 31.301 0 0 0-13.439-2.502c-4.427-.03-8.802.93-12.809 2.815a19.611 19.611 0 0 0-9.375 8.748h-.314V19.06c0-1.551-1.26-2.811-2.81-2.811h-9.376a2.813 2.813 0 0 0-2.814 2.81v78.128a2.814 2.814 0 0 0 2.814 2.812h10.309a2.814 2.814 0 0 0 2.815-2.813V72.814h.31c.938.937 1.877 2.187 3.125 3.437a17.459 17.459 0 0 0 4.688 3.125 29.149 29.149 0 0 0 6.25 2.5c2.663.656 5.387.972 8.127.938a34.716 34.716 0 0 0 12.812-2.5 32.76 32.76 0 0 0 10-7.188 31.86 31.86 0 0 0 6.558-10.94 37.847 37.847 0 0 0 2.192-13.435 37.847 37.847 0 0 0-2.192-13.438A39.338 39.338 0 0 0 190 24.063m-9.063 31.563a20.722 20.722 0 0 1-3.751 6.25 20.712 20.712 0 0 1-5.936 4.375 21.838 21.838 0 0 1-16.248 0 14.06 14.06 0 0 1-5.941-4.375 20.79 20.79 0 0 1-3.748-6.25 19.284 19.284 0 0 1-1.249-7.188 18.295 18.295 0 0 1 1.249-7.189A20.78 20.78 0 0 1 149.06 35a20.986 20.986 0 0 1 5.941-4.375 21.885 21.885 0 0 1 16.248 0A14.084 14.084 0 0 1 177.186 35a20.713 20.713 0 0 1 3.751 6.248 19.381 19.381 0 0 1 1.25 7.19 18.322 18.322 0 0 1-1.25 7.187M114.688 15.935h-9.374a2.816 2.816 0 0 0-2.814 2.815v6.875h-.31a22.8 22.8 0 0 0-9.376-8.75 29.57 29.57 0 0 0-12.812-2.813 36.771 36.771 0 0 0-13.44 2.5A30.588 30.588 0 0 0 56.25 23.75 27.152 27.152 0 0 0 50 34.69a37.905 37.905 0 0 0-2.188 13.433A37.94 37.94 0 0 0 50 61.563 35.189 35.189 0 0 0 56.563 72.5a25.618 25.618 0 0 0 10 7.188 28.434 28.434 0 0 0 12.812 2.5c2.74.03 5.467-.286 8.125-.938a28.82 28.82 0 0 0 6.25-2.5 30.321 30.321 0 0 0 4.688-3.125 31.27 31.27 0 0 0 3.124-3.438h.313v5.938c0 1.55 1.26 2.813 2.813 2.813H115a2.813 2.813 0 0 0 2.813-2.813V19.061a3.13 3.13 0 0 0-3.126-3.126m-14.06 39.69a20.902 20.902 0 0 1-3.752 6.25 20.765 20.765 0 0 1-5.936 4.375 21.848 21.848 0 0 1-16.252 0 14.036 14.036 0 0 1-5.937-4.375 20.856 20.856 0 0 1-3.75-6.25 19.383 19.383 0 0 1-1.248-7.188A18.33 18.33 0 0 1 65 41.248 20.847 20.847 0 0 1 68.75 35a20.968 20.968 0 0 1 5.938-4.375 21.895 21.895 0 0 1 16.251 0A14.09 14.09 0 0 1 96.875 35a20.893 20.893 0 0 1 3.752 6.248 19.48 19.48 0 0 1 1.248 7.19 18.392 18.392 0 0 1-1.248 7.187M302.5 23.75a29.518 29.518 0 0 0-11.25-6.875 41.145 41.145 0 0 0-13.75-2.502c-4.695.017-9.35.866-13.75 2.502a34.12 34.12 0 0 0-11.25 6.875 36.418 36.418 0 0 0-7.502 10.625 33.274 33.274 0 0 0-2.81 14.063c-.035 4.829.92 9.614 2.81 14.062a32.568 32.568 0 0 0 7.502 10.625A29.579 29.579 0 0 0 263.75 80a41.21 41.21 0 0 0 13.75 2.5 39.886 39.886 0 0 0 13.75-2.5 33.963 33.963 0 0 0 11.25-6.875A36.404 36.404 0 0 0 310 62.5a33.246 33.246 0 0 0 2.813-14.063A35.314 35.314 0 0 0 310 34.376a32.712 32.712 0 0 0-7.5-10.625m-7.188 31.875a20.736 20.736 0 0 1-3.75 6.25 20.747 20.747 0 0 1-5.937 4.375 21.843 21.843 0 0 1-16.25 0 14.036 14.036 0 0 1-5.938-4.375 20.856 20.856 0 0 1-3.75-6.25 19.305 19.305 0 0 1-1.25-7.188c-.07-2.45.36-4.904 1.25-7.189a20.847 20.847 0 0 1 3.75-6.248 21.01 21.01 0 0 1 5.938-4.375 21.89 21.89 0 0 1 16.25 0A14.084 14.084 0 0 1 291.563 35a20.727 20.727 0 0 1 3.75 6.248 19.481 19.481 0 0 1 1.25 7.19 18.322 18.322 0 0 1-1.25 7.187M389.063 35a34.264 34.264 0 0 0-6.25-10.938 28.145 28.145 0 0 0-10-7.187 31.292 31.292 0 0 0-13.438-2.502c-4.429-.03-8.809.93-12.813 2.815a19.607 19.607 0 0 0-9.375 8.748h-.312V19.06c0-1.551-1.26-2.811-2.813-2.811h-9.375a2.813 2.813 0 0 0-2.812 2.81v78.128a2.813 2.813 0 0 0 2.813 2.812H335a2.813 2.813 0 0 0 2.813-2.813V72.814h.312c.938.937 1.875 2.187 3.125 3.437a17.474 17.474 0 0 0 4.688 3.125 29.068 29.068 0 0 0 6.25 2.5c2.66.656 5.385.972 8.125.938 4.39-.015 8.74-.865 12.812-2.5a32.644 32.644 0 0 0 10-7.188 31.98 31.98 0 0 0 6.563-10.94 37.908 37.908 0 0 0 2.187-13.435A59.316 59.316 0 0 0 389.062 35M373.75 55.625a20.856 20.856 0 0 1-3.75 6.25 20.747 20.747 0 0 1-5.938 4.375 21.843 21.843 0 0 1-16.25 0 14.036 14.036 0 0 1-5.937-4.375 20.856 20.856 0 0 1-3.75-6.25 19.325 19.325 0 0 1-1.25-7.188 18.367 18.367 0 0 1 1.25-7.189 20.847 20.847 0 0 1 3.75-6.248 20.968 20.968 0 0 1 5.938-4.375 21.89 21.89 0 0 1 16.25 0A14.06 14.06 0 0 1 370 35a20.847 20.847 0 0 1 3.75 6.248 19.342 19.342 0 0 1 1.25 7.19 18.358 18.358 0 0 1-1.25 7.187M235.938 16.25h-11.252V2.815A2.812 2.812 0 0 0 221.875 0h-10.313a2.812 2.812 0 0 0-2.812 2.815v13.122h-4.688a2.812 2.812 0 0 0-2.812 2.813v7.813a2.812 2.812 0 0 0 2.813 2.812h4.687v30a47.322 47.322 0 0 0 .938 10 16.794 16.794 0 0 0 3.125 7.188 14.299 14.299 0 0 0 6.562 4.374 33.243 33.243 0 0 0 10.627 1.563 58.675 58.675 0 0 0 6.56-.625 3.123 3.123 0 0 0 2.5-2.813V71.25a3.123 3.123 0 0 0-3.125-2.813h-4.062a10.484 10.484 0 0 1-4.375-1.564l-.938-.934a13.77 13.77 0 0 1-1.876-7.814V30.002h11.251a2.813 2.813 0 0 0 2.811-2.813v-8.127a2.812 2.812 0 0 0-2.81-2.812"></path></svg> <img class="fallback" src="" data-fallback-src="https://vanilla.futurecdn.net/laptopmag/media/img/laptopmag_logo.svg">
</span>
<span class="hidden-header" itemprop="name">Laptop Mag</span> <span class="strapline"></span>
</a>
</div>
<input type="checkbox" name="burgerbar-expand" class="search-checkbox" id="search-checkbox">
<label class="button-search masthead-item " for="search-checkbox" onclick="">
<span class="desktop-text">Search</span>
<span class="icon icon-search">
<svg class="icon-image" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M720 124a422 422 0 1 0-73 654l221 222 132-131-222-222a422 422 0 0 0-58-523zm-92 504a291 291 0 1 1-412-412 291 291 0 0 1 412 411z"></path></svg> </span>
</label>
<form class="search-box" action="https://www.laptopmag.com/search" method="GET">
<input tabindex="0" type="search" name="searchTerm" placeholder="Search Laptop Mag" class="search-input">
<button type="submit" class="search-submit">
<span class="icon icon-search">
<svg class="icon-image" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M720 124a422 422 0 1 0-73 654l221 222 132-131-222-222a422 422 0 0 0-58-523zm-92 504a291 291 0 1 1-412-412 291 291 0 0 1 412 411z"></path></svg> </span>
</button>
</form>
<div class="nav-subscribe">
<div class="subscribe-text">Subscribe<span><svg preserveaspectratio="xMidYMid meet" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M1000 100L500 900 0 100h1000z"></path></svg></span></div>
</div>
<div class="other-links">
<a href="https://www.laptopmag.com/feeds/all">
<abbr title="Really Simple Syndication">RSS</abbr>
</a>
</div>
<div class="buttons-social masthead-item">
<a data-component-tracking-label="Facebook" target="_blank" href="https://www.facebook.com/laptopmag" class="icon icon-circle icon-facebook" aria-label="Facebook">
<svg class="icon-image" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#3b5998" r="12"></circle><path d="m13.079 19h-2.9v-7h-1.441v-2.408h1.442v-1.456c0-1.96.813-3.136 3.136-3.136h1.933v2.408h-1.2c-.91 0-.965.35-.965.966v1.218h2.183l-.257 2.408h-1.931z" fill="#fff"></path></svg> </a>
<a data-component-tracking-label="Twitter" target="_blank" href="https://twitter.com/laptopmag" class="icon icon-circle icon-twitter" aria-label="Twitter">
<svg class="icon-image" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#73b4ff" r="12"></circle><path d="m19.5 7.425a6.228 6.228 0 0 1 -1.77.465 2.979 2.979 0 0 0 1.35-1.665 6.234 6.234 0 0 1 -1.95.735 3.088 3.088 0 0 0 -5.325 2.07 3.021 3.021 0 0 0 .075.69 8.789 8.789 0 0 1 -6.33-3.165 2.985 2.985 0 0 0 -.42 1.53 3.016 3.016 0 0 0 1.37 2.52 3.082 3.082 0 0 1 -1.394-.39v.045a3.049 3.049 0 0 0 2.474 2.97 3.418 3.418 0 0 1 -1.4.06 3.076 3.076 0 0 0 2.881 2.1 6.233 6.233 0 0 1 -4.561 1.245 8.811 8.811 0 0 0 4.725 1.365 8.622 8.622 0 0 0 8.745-8.625v-.39a6.231 6.231 0 0 0 1.53-1.56z" fill="#fff"></path></svg> </a>
</div>
<div class="locale-selector-slice slice-container"><div class="locale-selector" data-reactroot=""><button type="button" class="locale-selector__trigger"><span class="locale-selector__text"></span><div class="locale-selector__icon--flag"></div><div class="locale-selector__icon--chevron-down"></div></button><div class="locale-selector__dropdown" style="display:none"><div class="locale-selector__dropdown__continents"><div class="locale-selector__dropdown__columns"><a class="locale-selector__option"><div class="locale-selector__option__icon-container"><div class="locale-selector__option__icon locale-selector__option__icon--flag"><svg xmlns="http://www.w3.org/2000/svg" id="flag-icon-css-us" viewbox="0 0 640 480"><g fill-rule="evenodd"><g stroke-width="1pt"><path fill="#bd3d44" d="M0 0h972.8v39.4H0zm0 78.8h972.8v39.4H0zm0 78.7h972.8V197H0zm0 78.8h972.8v39.4H0zm0 78.8h972.8v39.4H0zm0 78.7h972.8v39.4H0zm0 78.8h972.8V512H0z" transform="scale(.9375)"></path><path fill="#fff" d="M0 39.4h972.8v39.4H0zm0 78.8h972.8v39.3H0zm0 78.7h972.8v39.4H0zm0 78.8h972.8v39.4H0zm0 78.8h972.8v39.4H0zm0 78.7h972.8v39.4H0z" transform="scale(.9375)"></path></g><path fill="#192f5d" d="M0 0h389.1v275.7H0z" transform="scale(.9375)"></path><path fill="#fff" d="M32.4 11.8L36 22.7h11.4l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.3-6.7H29zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7h11.4zm64.8 0l3.6 10.9H177l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.3-6.7h11.5zm64.9 0l3.5 10.9H242l-9.3 6.7 3.6 11-9.3-6.8-9.3 6.7 3.6-10.9-9.3-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.2-6.7h11.4zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.6 11-9.3-6.8-9.3 6.7 3.6-10.9-9.3-6.7h11.5zM64.9 39.4l3.5 10.9h11.5L70.6 57 74 67.9l-9-6.7-9.3 6.7L59 57l-9-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.3 6.7 3.6 10.9-9.3-6.7-9.3 6.7L124 57l-9.3-6.7h11.5zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 10.9-9.2-6.7-9.3 6.7 3.5-10.9-9.2-6.7H191zm64.8 0l3.6 10.9h11.4l-9.3 6.7 3.6 10.9-9.3-6.7-9.2 6.7 3.5-10.9-9.3-6.7H256zm64.9 0l3.5 10.9h11.5L330 57l3.5 10.9-9.2-6.7-9.3 6.7 3.5-10.9-9.2-6.7h11.4zM32.4 66.9L36 78h11.4l-9.2 6.7 3.5 10.9-9.3-6.8-9.2 6.8 3.5-11-9.3-6.7H29zm64.9 0l3.5 11h11.5l-9.3 6.7 3.5 10.9-9.2-6.8-9.3 6.8 3.5-11-9.2-6.7h11.4zm64.8 0l3.6 11H177l-9.2 6.7 3.5 10.9-9.3-6.8-9.2 6.8 3.5-11-9.3-6.7h11.5zm64.9 0l3.5 11H242l-9.3 6.7 3.6 10.9-9.3-6.8-9.3 6.8 3.6-11-9.3-6.7h11.4zm64.8 0l3.6 11h11.4l-9.2 6.7 3.5 10.9-9.3-6.8-9.2 6.8 3.5-11-9.2-6.7h11.4zm64.9 0l3.5 11h11.5l-9.3 6.7 3.6 10.9-9.3-6.8-9.3 6.8 3.6-11-9.3-6.7h11.5zM64.9 94.5l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.3 6.7 3.6 11-9.3-6.8-9.3 6.7 3.6-10.9-9.3-6.7h11.5zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7H191zm64.8 0l3.6 10.9h11.4l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.3-6.7H256zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7h11.4zM32.4 122.1L36 133h11.4l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.3-6.7H29zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 10.9-9.2-6.7-9.3 6.7 3.5-10.9-9.2-6.7h11.4zm64.8 0l3.6 10.9H177l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.3-6.7h11.5zm64.9 0l3.5 10.9H242l-9.3 6.7 3.6 11-9.3-6.8-9.3 6.7 3.6-10.9-9.3-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.2-6.7h11.4zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.6 11-9.3-6.8-9.3 6.7 3.6-10.9-9.3-6.7h11.5zM64.9 149.7l3.5 10.9h11.5l-9.3 6.7 3.5 10.9-9.2-6.8-9.3 6.8 3.5-11-9.2-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.3 6.7 3.6 10.9-9.3-6.8-9.3 6.8 3.6-11-9.3-6.7h11.5zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 10.9-9.2-6.8-9.3 6.8 3.5-11-9.2-6.7H191zm64.8 0l3.6 10.9h11.4l-9.2 6.7 3.5 10.9-9.3-6.8-9.2 6.8 3.5-11-9.3-6.7H256zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 10.9-9.2-6.8-9.3 6.8 3.5-11-9.2-6.7h11.4zM32.4 177.2l3.6 11h11.4l-9.2 6.7 3.5 10.8-9.3-6.7-9.2 6.7 3.5-10.9-9.3-6.7H29zm64.9 0l3.5 11h11.5l-9.3 6.7 3.6 10.8-9.3-6.7-9.3 6.7 3.6-10.9-9.3-6.7h11.4zm64.8 0l3.6 11H177l-9.2 6.7 3.5 10.8-9.3-6.7-9.2 6.7 3.5-10.9-9.3-6.7h11.5zm64.9 0l3.5 11H242l-9.3 6.7 3.6 10.8-9.3-6.7-9.3 6.7 3.6-10.9-9.3-6.7h11.4zm64.8 0l3.6 11h11.4l-9.2 6.7 3.5 10.8-9.3-6.7-9.2 6.7 3.5-10.9-9.2-6.7h11.4zm64.9 0l3.5 11h11.5l-9.3 6.7 3.6 10.8-9.3-6.7-9.3 6.7 3.6-10.9-9.3-6.7h11.5zM64.9 204.8l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.3 6.7 3.6 11-9.3-6.8-9.3 6.7 3.6-10.9-9.3-6.7h11.5zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7H191zm64.8 0l3.6 10.9h11.4l-9.2 6.7 3.5 11-9.3-6.8-9.2 6.7 3.5-10.9-9.3-6.7H256zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.5 11-9.2-6.8-9.3 6.7 3.5-10.9-9.2-6.7h11.4zM32.4 232.4l3.6 10.9h11.4l-9.2 6.7 3.5 10.9-9.3-6.7-9.2 6.7 3.5-11-9.3-6.7H29zm64.9 0l3.5 10.9h11.5L103 250l3.6 10.9-9.3-6.7-9.3 6.7 3.6-11-9.3-6.7h11.4zm64.8 0l3.6 10.9H177l-9 6.7 3.5 10.9-9.3-6.7-9.2 6.7 3.5-11-9.3-6.7h11.5zm64.9 0l3.5 10.9H242l-9.3 6.7 3.6 10.9-9.3-6.7-9.3 6.7 3.6-11-9.3-6.7h11.4zm64.8 0l3.6 10.9h11.4l-9.2 6.7 3.5 10.9-9.3-6.7-9.2 6.7 3.5-11-9.2-6.7h11.4zm64.9 0l3.5 10.9h11.5l-9.3 6.7 3.6 10.9-9.3-6.7-9.3 6.7 3.6-11-9.3-6.7h11.5z" transform="scale(.9375)"></path></g></svg></div><span class="locale-selector__option__name">US</span></div><div class="locale-selector__option__icon locale-selector__option__icon--tick"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32 32"><path d="M26.744 3L11.419 18.423l-6.163-6.201L0 17.509 11.419 29 32 8.289z"></path></svg></div></a><a class="locale-selector__option"><div class="locale-selector__option__icon-container"><div class="locale-selector__option__icon locale-selector__option__icon--flag"><svg xmlns="http://www.w3.org/2000/svg" id="flag-icon-css-ca" viewbox="0 0 640 480"><path fill="#fff" d="M81.1 0h362.3v512H81.1z" transform="translate(74.1) scale(.9375)"></path><path fill="#d52b1e" d="M-100 0H81.1v512H-100zm543.4 0h181.1v512h-181zm-308 247.4l-14.2 4.8 65.5 57.5c5 14.7-1.7 19-6 26.8l71-9L250 399l14.8-.4-3.3-71 71.2 8.5c-4.4-9.3-8.3-14.2-4.3-29l65.4-54.5-11.4-4.2c-9.4-7.2 4-34.7 6-52.1 0 0-38.1 13.1-40.6 6.2l-9.8-18.7-34.7 38.2c-3.8.9-5.4-.6-6.3-3.8l16-79.8-25.4 14.3c-2.1 1-4.2.2-5.6-2.3l-24.5-49-25.2 50.9c-1.9 1.8-3.8 2-5.4.8l-24.2-13.6 14.6 79.1c-1.2 3.2-4 4-7.2 2.3l-33.3-37.7c-4.3 7-7.2 18.3-13 20.9-5.7 2.4-25-4.8-37.9-7.6 4.4 15.9 18.2 42.3 9.5 51z" transform="translate(74.1) scale(.9375)"></path></svg></div><span class="locale-selector__option__name">Canada</span></div><div class="locale-selector__option__icon locale-selector__option__icon--tick"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32 32"><path d="M26.744 3L11.419 18.423l-6.163-6.201L0 17.509 11.419 29 32 8.289z"></path></svg></div></a><a class="locale-selector__option"><div class="locale-selector__option__icon-container"><div class="locale-selector__option__icon locale-selector__option__icon--flag"><svg xmlns="http://www.w3.org/2000/svg" id="flag-icon-css-gb" viewbox="0 0 640 480"><path fill="#012169" d="M0 0h640v480H0z"></path><path fill="#FFF" d="M75 0l244 181L562 0h78v62L400 241l240 178v61h-80L320 301 81 480H0v-60l239-178L0 64V0h75z"></path><path fill="#C8102E" d="M424 281l216 159v40L369 281h55zm-184 20l6 35L54 480H0l240-179zM640 0v3L391 191l2-44L590 0h50zM0 0l239 176h-60L0 42V0z"></path><path fill="#FFF" d="M241 0v480h160V0H241zM0 160v160h640V160H0z"></path><path fill="#C8102E" d="M0 193v96h640v-96H0zM273 0v480h96V0h-96z"></path></svg></div><span class="locale-selector__option__name">UK</span></div><div class="locale-selector__option__icon locale-selector__option__icon--tick"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32 32"><path d="M26.744 3L11.419 18.423l-6.163-6.201L0 17.509 11.419 29 32 8.289z"></path></svg></div></a><a class="locale-selector__option"><div class="locale-selector__option__icon-container"><div class="locale-selector__option__icon locale-selector__option__icon--flag"><svg xmlns="http://www.w3.org/2000/svg" id="flag-icon-css-au" viewbox="0 0 640 480"><path id="path617" fill="#006" stroke-width="1.3" d="M0 0h640v480H0z"></path><path id="path625" fill="#fff" fill-rule="evenodd" stroke-width="1.3" d="M299.8 392.5l-43.7 3.8 6 43.4L232 408l-30.1 31.7 6-43.4-43.7-3.8 37.7-22.3-24.3-36.5 41 15.5 13.4-41.7 13.5 41.7 41-15.5-24.3 36.5m224.4 62.3L476 416.7l17.8 6.7 5.8-18.1 5.8 18.1 17.8-6.7-10.5 15.8 16.4 9.7-19 1.7 2.6 18.9-13-13.9-13.2 13.9 2.6-18.9-19-1.6m16.4-291.9L476 134.6l17.8 6.7 5.8-18.1 5.8 18.1 17.8-6.7-10.5 15.8 16.4 9.8-19 1.6 2.6 18.9-13-13.8-13.2 13.7 2.6-18.8-19-1.6M380.8 265l-10.5-15.8 17.8 6.7 5.8-18.1 5.9 18.1 17.8-6.7L407 265l16.4 9.7-19 1.7 2.7 18.9-13.2-13.9-13 13.9 2.5-18.9-19-1.6m216.3-38L570 221l17.8 6.7 5.8-18.1 5.9 18.1 17.8-6.7-10.5 15.8 16.3 9.7-19 1.7 2.6 18.8-13-13.8-13.2 13.8 2.6-18.8-19-1.7M542 320l-10.3 6.5 2.9-11.9-9.3-7.8 12.1-1 4.6-11.2 4.7 11.3 12.1.9-9.3 7.8 2.9 11.9"></path><path id="path969" fill="#006" stroke-width=".5" d="M0 0h320v240H0z"></path><path id="path971" fill="#fff" stroke-width=".5" d="M37.5 0l122 90.5L281 0h39v31l-120 89.5 120 89V240h-40l-120-89.5L40.5 240H0v-30l119.5-89L0 32V0z"></path><path id="path973" fill="#c8102e" stroke-width=".5" d="M212 140.5L320 220v20l-135.5-99.5zm-92 10l3 17.5-96 72H0zM320 0v1.5l-124.5 94 1-22L295 0zM0 0l119.5 88h-30L0 21z"></path><path id="path975" fill="#fff" stroke-width=".5" d="M120.5 0v240h80V0zM0 80v80h320V80z"></path><path id="path977" fill="#c8102e" stroke-width=".5" d="M0 96.5v48h320v-48zM136.5 0v240h48V0z"></path></svg></div><span class="locale-selector__option__name">Australia</span></div><div class="locale-selector__option__icon locale-selector__option__icon--tick"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32 32"><path d="M26.744 3L11.419 18.423l-6.163-6.201L0 17.509 11.419 29 32 8.289z"></path></svg></div></a></div></div></div></div></div>
</div>
</div>
<div class="nav-subscribe-widget-container"><div class="container-inner"><div class="block-message">Please deactivate your ad blocker in order to see our subscription offer</div></div></div>
<div class="wrapper">
<div class="menuitems container full">
<ul class="nav-list" data-component="nav">
<li class="menu-item menu-item-home" data-menuitem="">
<a data-component-tracking-label="home" class="home" href="https://www.laptopmag.com/">
<i class="icon icon-home"></i>
</a>
</li>
<li class="menu-item menu-item-news menu-level-1 has-submenu
">
<a href="https://www.laptopmag.com/news" aria-label="News">
<span>News</span>
</a>
</li>
<li class="menu-item menu-item-reviews menu-level-1 has-submenu
">
<a href="https://www.laptopmag.com/reviews" aria-label="Reviews">
<span>Reviews</span>
</a>
</li>
<li class="menu-item menu-item-best picks menu-level-1 has-submenu
">
<a href="https://www.laptopmag.com/best-picks" aria-label="Best Picks">
<span>Best Picks</span>
</a>
</li>
<li class="menu-item menu-item-laptops menu-level-1 has-submenu
">
<a href="https://www.laptopmag.com/laptops" aria-label="Laptops">
<span>Laptops</span>
</a>
</li>
<li class="menu-item menu-item-tablets menu-level-1 has-submenu
">
<a href="https://www.laptopmag.com/tablets" aria-label="Tablets">
<span>Tablets</span>
</a>
</li>
<li class="menu-item menu-item-headphones menu-level-1 has-submenu
">
<a href="https://www.laptopmag.com/tag/headphones" aria-label="Headphones">
<span>Headphones</span>
</a>
</li>
<li class="menu-item menu-item-more menu-level-1 has-submenu
menu-item-hover-reveal ">
More
<i class="icon icon-arrow-down"></i><i class="icon icon-arrow-right"></i>
<ul class="sub-menu" data-more-submenu="">
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/articles/laptop-buying-guide" aria-label="Laptop Buying Guide">Laptop Buying Guide</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/articles/laptop-brand-ratings" aria-label="Laptop Brands">Laptop Brands</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/benchmarks/cpu-performance" aria-label="CPU Performance">CPU Performance</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/articles/best-laptops-for-college" aria-label="College Laptops">College Laptops</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/articles/best-gaming-laptops" aria-label="Gaming Laptops">Gaming Laptops</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/articles/best-laptops-for-video-editing" aria-label="Video Editing Laptops">Video Editing Laptops</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/reviews/best-chromebooks-5" aria-label="Chromebooks">Chromebooks</a>
</li>
<li class="sub-menu-item menu-level-2 primary-style">
<a href="https://www.laptopmag.com/articles/best-apple-laptops" aria-label="Apple Laptops">Apple Laptops</a>
</li>
</ul>
</li>
</ul>
<div class="nav-sub-set-container">
<div class="menu-item menu-item-none menu-item-main-pro menu-item-nav-sub-set">
<a href="https://forums.tomsguide.com" target="_blank">Forums</a>
</div>
</div> </div>
</div>
</nav><div class="dfp-leaderboard-container">
<div class="dfp-leaderboard-background"></div>
</div>
<div id="main" class="container full " tabindex="-1">
<div class="trending-wrapper ">
<div class="trending-bar container full">
<div class="trending-lead brands-disabled">
Trending
</div>
<ul class="trending-items ">
<li class="trending-item"> <a href="https://www.laptopmag.com/news/live/apple-wwdc-2021-live-blog-latest-updates-on-ios-15-macos-and-more">WWDC Live blog</a></li>
<li class="trending-item"> <a href="https://www.laptopmag.com/reviews/best-laptops-1">Best laptops</a></li>
<li class="trending-item"> <a href="https://www.laptopmag.com/news/microsoft-surface-pro-8-rumors-release-date-price-and-what-we-want">Surface Pro 8 </a></li>
<li class="trending-item"> <a href="https://www.laptopmag.com/news/nvidia-unveils-geforce-rtx-3050-and-rtx-3050-ti-gpus-what-you-need-to-know">Nvidia RTX 3050 Ti</a></li>
<li class="trending-item"> <a href="https://laptopmag.com/news/razer-sliced-open-the-blade-advanced-15-and-added-11th-gen-intel-h-series-cpus">New Razer Blade Advanced 15</a></li>
<!-- Start Trending Subset //-->
<!-- End Trending Subset //-->
</ul>
</div>
</div>
<aside id="affiliate-disclaimer" data-reactroot=""><p class="affiliate-disclaimer__copy">LaptopMag is supported by its audience. When you purchase through links on our site, we may earn an affiliate commission. <a href="https://www.futureplc.com/terms-conditions/">Learn more</a></p></aside>
<div id="top-leaderboard" class="ad-unit"></div>
<article class="review-article" data-id="H98JCEZtvf3Udyt82RtYNG">
<div id="article-top" class="ad-unit"></div>
<div class="header-container">
<nav class="breadcrumb" aria-label="Breadcrumbs">
<ol>
<li><a href="https://www.laptopmag.com/">Home</a></li>
<li><a href="https://www.laptopmag.com/reviews">Reviews</a></li>
</ol>
</nav>
<header>
<div class="header-sub-container">
<h1 class="review-title-long">iPad Pro 2021 (12.9-inch) review</h1>
<h2>The iPad Pro 2021 (12.9-inch) is the most advanced tablet ever although the new upgrades aren't always noticeable
</h2>
<p class="byline">
<span class="chunk rating">
<span class="icon icon-star"> </span>
<span class="icon icon-star"> </span>
<span class="icon icon-star"> </span>
<span class="icon icon-star"> </span>
<span class="icon icon-star half"></span>
</span>
By
<span class="no-wrap by-author"><a href="https://www.laptopmag.com/author/phillip-tracy" rel="author"><span style="white-space: nowrap">Phillip Tracy</span></a></span>
<time itemprop="datePublished" class="no-wrap relative-date chunk" datetime="2021-06-15T22:00:49Z">15 June 2021</time>
</p>
<nav class="socialite-widget box less-space " data-contexturl="https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review">
<ul class="socialite-widget-ul">
<li class="socialite-widget-item">
<a data-component-tracking-label="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review" data-platform="facebook" target="_blank" class="facebook socialite" data-action="share" aria-label="Facebook">
<svg class="icon-image" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#3b5998" r="12"></circle><path d="m13.079 19h-2.9v-7h-1.441v-2.408h1.442v-1.456c0-1.96.813-3.136 3.136-3.136h1.933v2.408h-1.2c-.91 0-.965.35-.965.966v1.218h2.183l-.257 2.408h-1.931z" fill="#fff"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Twitter" href="https://twitter.com/intent/tweet?text=iPad%20Pro%202021%20%2812.9-inch%29%20review&amp;url=https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review" data-platform="twitter" target="_blank" class="twitter socialite" data-action="tweet" aria-label="Twitter">
<svg class="icon-image" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><circle cx="12" cy="12" fill="#73b4ff" r="12"></circle><path d="m19.5 7.425a6.228 6.228 0 0 1 -1.77.465 2.979 2.979 0 0 0 1.35-1.665 6.234 6.234 0 0 1 -1.95.735 3.088 3.088 0 0 0 -5.325 2.07 3.021 3.021 0 0 0 .075.69 8.789 8.789 0 0 1 -6.33-3.165 2.985 2.985 0 0 0 -.42 1.53 3.016 3.016 0 0 0 1.37 2.52 3.082 3.082 0 0 1 -1.394-.39v.045a3.049 3.049 0 0 0 2.474 2.97 3.418 3.418 0 0 1 -1.4.06 3.076 3.076 0 0 0 2.881 2.1 6.233 6.233 0 0 1 -4.561 1.245 8.811 8.811 0 0 0 4.725 1.365 8.622 8.622 0 0 0 8.745-8.625v-.39a6.231 6.231 0 0 0 1.53-1.56z" fill="#fff"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review&amp;title=iPad%20Pro%202021%20%2812.9-inch%29%20review&amp;source=www.laptopmag.com" data-platform="linkedin" target="_blank" class="linkedin socialite" data-action="share" aria-label="LinkedIn">
<svg class="icon-image" xmlns="http://www.w3.org/2000/svg" width="24" height="23" viewbox="0 1 24 23"><path fill="#FFF" d="M4.98 3.5C4.98 4.881 3.87 6 2.5 6S.02 4.881.02 3.5C.02 2.12 1.13 1 2.5 1s2.48 1.12 2.48 2.5zM5 8H0v16h5V8zm7.982 0H8.014v16h4.968v-8.398c0-4.67 6.029-5.053 6.029 0V24H24V13.869c0-7.88-8.922-7.593-11.018-3.714V8z"></path></svg> </a>
</li>
<li class="socialite-widget-item mobile-only">
<a data-component-tracking-label="Whatsapp" href="whatsapp://send?text=iPad%20Pro%202021%20(12.9-inch)%20reviewhttps://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review?fwa" data-platform="whatsapp" class="whatsapp socialite" data-action="message" aria-label="WhatsApp">
<svg class="icon-image" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 1000 1000"><path d="M509 0A489 489 0 0 0 18 487a482 482 0 0 0 71 252L0 1000l272-86a493 493 0 0 0 237 60c271 0 491-218 491-487S780 0 509 0zm0 893a409 409 0 0 1-225-67l-157 49 51-150a401 401 0 0 1-78-238 408 408 0 0 1 818 0c0 224-184 406-409 406zm230-295a2222 2222 0 0 0-84-44c-11-4-20-7-28 5a748 748 0 0 1-42 48c-7 8-15 8-27 2-12-7-52-22-99-66a372 372 0 0 1-66-88c-7-13 0-20 7-26l19-21c7-7 9-12 13-20 5-8 3-15 0-22l-35-94c-9-25-20-21-27-21l-24-2c-8 0-22 2-34 14s-46 41-48 102 40 122 46 131c6 8 82 141 207 195 126 55 126 38 149 37 24-1 76-27 87-56 12-29 13-54 10-59s-11-9-24-15z"></path></svg> </a>
</li>
<li class="socialite-widget-item">
<a data-component-tracking-label="Email" href="mailto:?subject=I%20found%20this%20webpage&amp;body=Hi,%20I%20found%20this%20webpage%20and%20thought%20you%20might%20like%20it%20https://www.laptopmag.com/reviews/ipad-pro-2021-129-inch-review" class="email socialite" data-platform="email" aria-label="Email">
<i class="icon icon-envelope-solid"></i>
</a>
</li>
</ul>
</nav>
</div>
</header>
<div class="center-cropped landscape" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<div class="games-plus-sign-overlay"></div>
<picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class=" block-image-ads hero-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" srcset="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-480-80.jpg.webp 480w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-768-80.jpg.webp 768w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-1024-80.jpg.webp 1024w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-1200-80.jpg.webp 1200w" sizes="(min-width: 1000px) 920px, (min-width: 575px) calc(100vw - 40px), 100vw" data-original-mos="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg" data-pin-nopin="true"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class=" block-image-ads hero-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" srcset="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-480-80.jpg 480w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-768-80.jpg 768w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-1024-80.jpg 1024w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-1200-80.jpg 1200w" sizes="(min-width: 1000px) 920px, (min-width: 575px) calc(100vw - 40px), 100vw" data-original-mos="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg" data-pin-nopin="true"></source><img src="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-480-80.jpg" alt="iPad Pro 2021 (12.9-inch)" class=" block-image-ads hero-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" srcset="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-480-80.jpg 480w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-768-80.jpg 768w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-1024-80.jpg 1024w, https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi-1200-80.jpg 1200w" sizes="(min-width: 1000px) 920px, (min-width: 575px) calc(100vw - 40px), 100vw" data-original-mos="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg" data-pin-nopin="true"></picture>
<div class="award-placeholder sprite-award-editors-choice sprite-award-editors-choice_2021 ">Editor's Choice</div>
<meta itemprop="url" content="https://cdn.mos.cms.futurecdn.net/WBbAyMHCVrBrJ3jnVmSxCi.jpg">
<meta itemprop="height" content="456">
<meta itemprop="width" content="920">
</div>
<div class="credit">(Image: © Laptop Mag)</div>
</div>
<div id="content-after-image">
<section class="content-wrapper">
<div class="box contrast less-space verdict">
<div class="sub-box full">
<h3>Our Verdict</h3>
<p>Apple's iPad Pro 2021 brings display, processor and connectivity upgrades to what was already the world's best (and most expensive) tablet. </p>
</div>
</div>
<div class="box contrast less-space pro-con">
<div class="sub-box">
<h4 class="icon icon-plus_circle">
For
</h4>
<ul>
<li>
XDR display can get bright and vivid
</li>
<li>
M1 chip is outrageously fast
</li>
<li>
Slim, durable chassis
</li>
<li>
Thunderbolt 3 and USB4 support
</li>
<li>
Improved front-facing camera with Center Stage
</li>
<li>
5G wireless speeds
</li>
</ul>
</div>
<div class="sub-box">
<h4 class="icon icon-minus_circle">
Against
</h4>
<ul>
<li>
Display has some limitations
</li>
<li>
iPadOS can feel restricting
</li>
<li>
Expensive
</li>
<li>
</li>
</ul>
</div>
</div>
<div class="ratingVerdict" id="best-price-article-top">
</div>
<div class="left-rail-area"></div>
<div id="article-body" class="text-copy bodyCopy auto">
<aside class="hawk-placeholder" data-model-name="iPad_Pro_2021" data-name="TOP widget" data-render-type="fte" data-skip="editorial" data-widget-type="review"></aside><aside class="hawk-placeholder" data-model-name="Apple iPad Pro 12.9 (2021)" data-widget-type="review" data-render-type="editorial"><div class="hawk-main-editorial"><div class="hawk-title-container">Today's best Apple iPad Pro 12.9 (2021) deals</div><div class="hawk-grid-items-container" data-stacked="0"><div class="hawk-grid-item-container" data-expandable="0" data-stacked="0"><div class="hawk-grid-item-main-container hawk-grid-item-main-bundle" data-product-type="1000" data-button-type="chevron" data-stacked="0" data-expanded="0"><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="image" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-images-container"><div class="hawk-deal-image-container"><a href="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="2935-B0932BKSLP" data-url="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-bundle"><div class="hawk-lazy-load-placeholder"></div></div></a></div><div class="hawk-bundle-images-main"></div></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="models" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-models-container"><a href="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="2935-B0932BKSLP" data-url="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" data-model-id="856055"><div class="hawk-display-name-bundle">Apple iPad Pro 12.9 (2021) (128GB</div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="merchant" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-deal-image-container" data-type="merchant"><a href="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="2935-B0932BKSLP" data-url="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-merchant"><div class="hawk-lazy-load-placeholder">Amazon</div></div></a></div><div class="hawk-amazon-prime-shipping-container"><div class="hawk-lazy-load-container hawk-lazy-load-prime"><div class="hawk-lazy-load-placeholder">Prime</div></div></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="priceLink" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-main-price-chevron"><div><a href="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="2935-B0932BKSLP" data-url="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" data-model-id="856055"><div class="hawk-display-price-container" data-type="retail"><span class="hawk-display-price-price">$1,099</span></div></a></div></div><a href="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="2935-B0932BKSLP" data-url="https://target.georiot.com/Proxy.ashx?tsid=45727&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fdp%2FB0932BKSLP%3Ftag%3Dhawk-future-20%26linkCode%3Dogi%26th%3D1%26psc%3D1%26ascsubtag%3Dlaptopmag-us-5511866170103524000-20" data-model-id="856055"><svg viewbox="0 0 9 28" enable-background="new 0 0 15 15" xml:space="preserve" class="hawk-arrow-right-svg"><path class="hawk-arrow-right-path" d="M9.297 15c0 0.125-0.063 0.266-0.156 0.359l-7.281 7.281c-0.094 0.094-0.234 0.156-0.359 0.156s-0.266-0.063-0.359-0.156l-0.781-0.781c-0.094-0.094-0.156-0.219-0.156-0.359 0-0.125 0.063-0.266 0.156-0.359l6.141-6.141-6.141-6.141c-0.094-0.094-0.156-0.234-0.156-0.359s0.063-0.266 0.156-0.359l0.781-0.781c0.094-0.094 0.234-0.156 0.359-0.156s0.266 0.063 0.359 0.156l7.281 7.281c0.094 0.094 0.156 0.234 0.156 0.359z"></path></svg></a></div></div></div><div class="hawk-grid-item-container" data-expandable="0" data-stacked="0"><div class="hawk-grid-item-main-container hawk-grid-item-main-bundle" data-product-type="1000" data-button-type="chevron" data-stacked="0" data-expanded="0"><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="image" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-images-container"><div class="hawk-deal-image-container"><a href="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="54684-APMHNG3LLA" data-url="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-bundle"><div class="hawk-lazy-load-placeholder"></div></div></a></div><div class="hawk-bundle-images-main"></div></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="models" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-models-container"><a href="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="54684-APMHNG3LLA" data-url="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" data-model-id="856055"><div class="hawk-display-name-bundle">Apple iPad Pro 12.9 (2021)</div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="merchant" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-deal-image-container" data-type="merchant"><a href="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="54684-APMHNG3LLA" data-url="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-merchant"><div class="hawk-lazy-load-placeholder">BHPhoto</div></div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="priceLink" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-main-price-chevron"><div><a href="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="54684-APMHNG3LLA" data-url="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" data-model-id="856055"><div class="hawk-display-price-container" data-type="retail"><span class="hawk-display-price-price">$1,099</span></div></a></div></div><a href="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="54684-APMHNG3LLA" data-url="https://www.bhphotovideo.com/c/product/1636229-REG/apple_mhng3ll_a_12_9_ipad_pro_wifi.html/BI/20811/KBID/16572?SID=laptopmag-us-7634141815810662000" data-model-id="856055"><svg viewbox="0 0 9 28" enable-background="new 0 0 15 15" xml:space="preserve" class="hawk-arrow-right-svg"><path class="hawk-arrow-right-path" d="M9.297 15c0 0.125-0.063 0.266-0.156 0.359l-7.281 7.281c-0.094 0.094-0.234 0.156-0.359 0.156s-0.266-0.063-0.359-0.156l-0.781-0.781c-0.094-0.094-0.156-0.219-0.156-0.359 0-0.125 0.063-0.266 0.156-0.359l6.141-6.141-6.141-6.141c-0.094-0.094-0.156-0.234-0.156-0.359s0.063-0.266 0.156-0.359l0.781-0.781c0.094-0.094 0.234-0.156 0.359-0.156s0.266 0.063 0.359 0.156l7.281 7.281c0.094 0.094 0.156 0.234 0.156 0.359z"></path></svg></a></div></div></div><div class="hawk-grid-item-container" data-expandable="0" data-stacked="0"><div class="hawk-grid-item-main-container hawk-grid-item-main-bundle" data-product-type="1000" data-button-type="chevron" data-stacked="0" data-expanded="0"><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="image" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-images-container"><div class="hawk-deal-image-container"><a href="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="131993-4264601" data-url="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-bundle"><div class="hawk-lazy-load-placeholder"></div></div></a></div><div class="hawk-bundle-images-main"></div></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="models" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-models-container"><a href="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="131993-4264601" data-url="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" data-model-id="856055"><div class="hawk-display-name-bundle">Apple iPad Pro 12.9 (2021)</div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="merchant" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-deal-image-container" data-type="merchant"><a href="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="131993-4264601" data-url="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-merchant"><div class="hawk-lazy-load-placeholder">Best Buy</div></div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="priceLink" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-main-price-chevron"><div><a href="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="131993-4264601" data-url="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" data-model-id="856055"><div class="hawk-display-price-container" data-type="retail"><span class="hawk-display-price-price">$1,099.99</span></div></a></div></div><a href="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="131993-4264601" data-url="https://shop-links.co/link/?publisher_slug=future&amp;u1=laptopmag-us-1326375511112735000&amp;exclusive=1&amp;url=https%3A%2F%2Fbestbuy.7tiv.net%2Fc%2F376373%2F633495%2F10014%3Fprodsku%3D4264601%26u%3Dhttp%253A%252F%252Fwww.bestbuy.com%252Fsite%252F-%252F4264601.p%253Fcmp%253DRMX&amp;article_name=iPad%20Pro%202021%20(12.9-inch)%20review&amp;article_url=https%3A%2F%2Fwww.laptopmag.com%2Freviews%2Fipad-pro-2021-129-inch-review" data-model-id="856055"><svg viewbox="0 0 9 28" enable-background="new 0 0 15 15" xml:space="preserve" class="hawk-arrow-right-svg"><path class="hawk-arrow-right-path" d="M9.297 15c0 0.125-0.063 0.266-0.156 0.359l-7.281 7.281c-0.094 0.094-0.234 0.156-0.359 0.156s-0.266-0.063-0.359-0.156l-0.781-0.781c-0.094-0.094-0.156-0.219-0.156-0.359 0-0.125 0.063-0.266 0.156-0.359l6.141-6.141-6.141-6.141c-0.094-0.094-0.156-0.234-0.156-0.359s0.063-0.266 0.156-0.359l0.781-0.781c0.094-0.094 0.234-0.156 0.359-0.156s0.266 0.063 0.359 0.156l7.281 7.281c0.094 0.094 0.156 0.234 0.156 0.359z"></path></svg></a></div></div></div><div class="hawk-grid-item-container" data-expandable="0" data-stacked="0"><div class="hawk-grid-item-main-container hawk-grid-item-main-bundle" data-product-type="1000" data-button-type="chevron" data-stacked="0" data-expanded="0"><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="image" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-images-container"><div class="hawk-deal-image-container"><a href="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="66577-sku1240037" data-url="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-bundle"><div class="hawk-lazy-load-placeholder"></div></div></a></div><div class="hawk-bundle-images-main"></div></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="models" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-bundle-models-container"><a href="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="66577-sku1240037" data-url="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" data-model-id="856055"><div class="hawk-display-name-bundle">Apple iPad Pro 12.9 (2021) (128GB)</div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="merchant" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-deal-image-container" data-type="merchant"><a href="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="66577-sku1240037" data-url="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" data-model-id="856055"><div class="hawk-lazy-load-container hawk-lazy-load-merchant"><div class="hawk-lazy-load-placeholder">AT&amp;T</div></div></a></div></div><div class="hawk-grid-item-block-container hawk-grid-item-block-bundle" data-name="priceLink" data-product-type="1000" data-button-type="chevron" data-stacked="0"><div class="hawk-main-price-chevron"><div><a href="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="66577-sku1240037" data-url="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" data-model-id="856055"><div class="hawk-display-price-container" data-type="retail"><span class="hawk-display-price-price">$1,299.99</span></div></a></div></div><a href="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" target="_blank" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" class="hawk-affiliate-link-container" data-product-key="66577-sku1240037" data-url="https://www.dpbolvw.net/click-8957516-13664766?url=http%3A%2F%2Ftracking.searchmarketing.com%2Fclick.asp%3Faid%3D330002190000021341&amp;cjsku=sku1240037&amp;sid=laptopmag-us-7012196511960125000" data-model-id="856055"><svg viewbox="0 0 9 28" enable-background="new 0 0 15 15" xml:space="preserve" class="hawk-arrow-right-svg"><path class="hawk-arrow-right-path" d="M9.297 15c0 0.125-0.063 0.266-0.156 0.359l-7.281 7.281c-0.094 0.094-0.234 0.156-0.359 0.156s-0.266-0.063-0.359-0.156l-0.781-0.781c-0.094-0.094-0.156-0.219-0.156-0.359 0-0.125 0.063-0.266 0.156-0.359l6.141-6.141-6.141-6.141c-0.094-0.094-0.156-0.234-0.156-0.359s0.063-0.266 0.156-0.359l0.781-0.781c0.094-0.094 0.234-0.156 0.359-0.156s0.266 0.063 0.359 0.156l7.281 7.281c0.094 0.094 0.156 0.234 0.156 0.359z"></path></svg></a></div></div></div></div><div class="hawk-load-more-alpine hawk-load-more-more-deals-container"><div class="hawk-load-more-load-more-container"><span class="hawk-load-more-load-more">Show More Deals</span></div><div class="hawk-load-more-show-less-container"></div></div><div class="hawk-footer-container"><div class="hawk-footer-description">We check over 250 million products every day for the best prices</div><div class="hawk-powered-by-container"></div></div></div></aside><div class="fancy-box"><div class="fancy_box-title">iPad Pro 2021 (12.9 inch) specs</div><div class="fancy_box_body"><p><strong>Price: </strong>$1,099 (starting)<strong><br>
OS: </strong>iPadOS 14.5<strong><br>
CPU:</strong> M1<br>
<strong>Storage: </strong>128GB, 256GB, 512GB, 1TB, 2TB<br>
<strong>Display: </strong>12.9 inches (2732 x 2048 pixels) mini-LED<br>
<strong>Rear cameras:</strong> 12MP wide (f/1.8), 10-MP ultra-wide (f/2.4)<br>
<strong>Video:</strong> 4K up to 60 fps<br>
<strong>Front camera: </strong>12MP TrueDepth<br>
<strong>Wireless: </strong>Wi-Fi 6, 5G<br>
<strong>Battery life (tested): </strong>10 hours 48 minutes<br>
<strong>Size:</strong> 11.04 x 8.46 x 0.25 inches<br>
<strong>Weight: </strong>1.5 pounds</p></div></div><p>When a <a href="https://www.laptopmag.com/best-tablets">tablet</a> arrives with major upgrades to its processor, display and wireless connectivity, you expect it to feel like a new experience. That isn't the case with the iPad Pro 2021. At least, not initially. Out of the box, the iPad Pro acts much like its predecessor. It's lightning-fast, has a gorgeous 12.9-inch display, and is as feature-packed as ever &mdash; so where is the added spice?</p><div id="ad-unit-1" class="ad-unit"></div><p>Don't worry, the iPad Pro 2021 is a product you'll appreciate the more you use it. The new Liquid Retina XDR display with mini-LED technology may not blow you away initially, but playing HDR content showcases how much brighter and more vivid it can get compared to previous Retina panels. While the M1 brings huge performance gains, you probably won't notice them until you've put this tablet to the test by running intensive apps or workflows. Then there is the addition of 5G, which is still several years away from reaching its true potential.&nbsp;</p><ul><li><a href="https://www.laptopmag.com/articles/ipad-buying-guide">iPad Pro vs. iPad mini vs. iPad</a>: Which tablet is best?</li><li><a href="https://www.laptopmag.com/articles/macbook-vs-air-vs-pro">MacBook Air vs. MacBook Pro</a>: Which laptop should you buy?</li><li><a href="https://www.laptopmag.com/articles/best-cheap-tablets">Best cheap tablet deals</a> in 2021</li></ul><aside class="hawk-placeholder" data-model-name="iPad_Pro_2021" data-name="Inbody widget" data-render-type="fte" data-skip="phones" data-widget-type="inbody"></aside><aside class="hawk-placeholder" data-render-type="fte" data-skip="dealsy" data-widget-type="seasonal"></aside><p>These additions, combined with more straightforward upgrades like Thunderbolt 3 support and an improved front-facing camera, make the iPad Pro 2021 the best Apple tablet ever. They don't, however, make the iPad Pro the go-to tablet for everyone. Let's find out why.</p><h2 id="ipad-pro-price-and-configuration-options-xa0">iPad Pro price and configuration options&nbsp;</h2><p>The iPad Pro 2021 (12.9-inch) starts at $1,099 for the 128GB Wi-Fi model with 8GB of RAM, making it $100 more expensive than the previous model. Doubling storage to 256GB brings the price to $1,199. From there, you can buy a 512GB model for $1,399, or pay $1,799 for 1TB and 16GB of RAM. If you can't store in the cloud, or work with gigantic files, the 2TB model with 16GB of RAM costs $2,199.&nbsp;</p><div class="van_vid_carousel"><div class="van_vid_carousel__padding"><div class="van_vid_carousel__container"><svg width="45" height="64" viewbox="0 0 45 64" xmlns="http://www.w3.org/2000/svg"><path d="M44.99394 31.4744L0 63.5v-64z" fill="#CCC" fill-rule="evenodd"></path></svg></div></div></div><p>Opting for a cellular model with 5G support adds $200 to the price of the Wi-Fi configurations.</p><div id="ad-unit-2" class="ad-unit"></div><h2 id="ipad-pro-design-xa0">iPad Pro design&nbsp;</h2><p>Identical to the previous model, apart from some added weight (more on that later), the iPad Pro is a stylish slate with a sophisticated aluminum design, slim display bezels and a flat-edge shape.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1999px;"><p class="vanilla-image-block" style="padding-top:56.23%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/FrVgtGANDq4Ji8N8XMwuLj.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>Apple brought fresh colors to the <a href="https://www.laptopmag.com/reviews/ipad-air-4">iPad Air</a>, <a href="https://www.laptopmag.com/news/imac-2021-revealed-at-apples-spring-loaded-event">iMac</a> and <a href="https://www.laptopmag.com/reviews/iphone-12">iPhone 12</a>, but the iPad Pro is stuck with bland Space Gray and boring Silver. Perhaps suit-wearing execs want gadgets with a discrete, professional appearance. But come on, Apple, have some fun! After all, content creators, the other group the iPad Pro targets, want some pizzazz in their life.</p><p>The rear of the iPad Pro sports a centered chrome Apple logo below a squircle camera module housing dual vertically oriented lenses and a LiDAR sensor (much like the iPhone 12). Gray antenna bands hug the top and bottom of the slate.&nbsp;</p><div id="in-article" class="ad-unit"></div><p>The edges of the iPad Pro are flat, which gives the slab a stately stature while the aluminum frame feels robust. Lining those flat edges is a power button on the top-right corner, volume up and down buttons and a SIM card slot on the right, and a USB port on the bottom. The front-facing camera is located at the top when the tablet is vertically orientated, which can be problematic (more on that later).</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:6048px;"><p class="vanilla-image-block" style="padding-top:56.22%;"><picture><source type="image/webp" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/3SBem6nTJnsTd8nw3AEkKh.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>My two favorite hardware features are the thin bezels bordering the display; they draw your eyes toward the gorgeous 12.9-inch panel. The other is the charging pad, which magnetically holds and tops off the Apple Pencil 2.&nbsp;</p><p>At 11 x 8.5 x 0.25 inches and 1.5 pounds, the iPad Pro 2021 is slightly bulkier than the <a href="https://www.laptopmag.com/reviews/ipad-pro-12-9-2020">iPad Pro 2020</a> (11.04 x 8.46 x 0.23 inches, 1.41 pounds), and heavier than the <a href="https://www.laptopmag.com/reviews/samsung-galaxy-tab-s7-and-galaxy-tab-s7-plus"><u>Samsung Galaxy Tab S7 Plus</u></a> (10 x 6.51 x 0.25 inches, 1.3 pounds). The <a href="https://www.laptopmag.com/reviews/microsoft-surface-pro-7-plus"><u>Microsoft Surface Pro 7+</u></a> is a chunkier tablet both in size (11.5 x 7.9 x 0.3 inches) and weight (1.8 pounds).&nbsp;</p><h2 id="ipad-pro-ports-xa0">iPad Pro ports&nbsp;</h2><p>The iPad Pro has a single <a href="https://www.laptopmag.com/articles/usb-c-cable-types"><u>USB-C</u></a> charging port on the bottom edge with Thunderbolt 3 and USB4 support.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/XFydovr2dQN7gWDE3m3P4g.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>That gets you data throughput of up to 40Gbps (up from 10Gbps) and the ability to connect to 4K and 5K monitors along with compatibility with a range of USB-C accessories.</p><h2 id="ipad-pro-display-xa0">iPad Pro display&nbsp;</h2><p>The new Liquid Retina XDR display feels more like an evolution of LED than the revolution OLED sparked. Colors are vibrant and the screen gets very bright, but don't expect the same eye-popping tones found on the Galaxy Tab S7 Pro's AMOLED panel. Part of the reason, I suspect, is that Apple wants to keep its signature "natural" look; colors on the 12.9-inch screen are accurate without being oversaturated. But as a result, the screen on the new iPad Pro doesn't look much different than its predecessor &mdash; at least while viewing non-HDR content (most TV shows and movies on streaming services).</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:6048px;"><p class="vanilla-image-block" style="padding-top:56.22%;"><picture><source type="image/webp" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/oP5ABJnCi4QgUyqMXr7uJi.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>I don't mean to suggest that non-HDR content looks bad, quite the contrary. In a 1080p trailer for Free Guys, Ryan Reynold's sky blue shirt was so sharp, I wanted to reach out and touch it. The blood caked onto his broken nose was a rich merlot and the freshly painted cars parked in a hangar were like Skittles; every color of the rainbow.&nbsp;</p><p>Everything changes when you watch an HDR video in full-screen mode. The brightness jumps up to absurd levels, allowing the colors to burst off the screen. Photo quality becomes much closer to what you find on an OLED TV or laptop panel.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:6048px;"><p class="vanilla-image-block" style="padding-top:56.22%;"><picture><source type="image/webp" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/tbog9YM5jsaMRdtMad8W9j.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>Now let's talk about the worm in this Apple, or what is being referred to as "<a href="https://www.laptopmag.com/news/ipad-pro-2021-liquid-retina-xr-display-could-have-mini-led-issue-what-we-know">blooming</a>." This is when bright pixels bleed into nearby dark pixels causing them to glow. Before you get angry at Apple, the problem stems from the underlying mini-LED technology. Instead of a uniform backlight, mini-LED consists of 2,500 local dimming zones that can illuminate during bright scenes or turn off completely during dark ones. Apple already acknowledged the blooming effect in a <a href="https://apple.sjv.io/c/221109/473657/7613?subId1=laptopmag-us-5584600309651976000&amp;u=https%3A%2F%2Fsupport.apple.com%2F%3Fafid%3Dp239%257C221109%26cid%3Daos-us-aff-ir" data-url="https://support.apple.com/?afid=p239%7C221109&amp;cid=aos-us-aff-ir" target="_blank" data-hl-processed="hawklinks" data-placeholder-url="https://apple.sjv.io/c/221109/473657/7613?subId1=hawk-custom-tracking&amp;u=https%3A%2F%2Fsupport.apple.com%2F%3Fafid%3Dp239%257C221109%26cid%3Daos-us-aff-ir" rel="nofollow noopener" referrerpolicy="no-referrer-when-downgrade" data-merchant-name="apple.com" data-merchant-id="30557">support document</a>.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/bnkLqtt3E44cJTmoFLoTYh.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>I noticed the blooming only in certain settings menus and when I intentionally replicated the conditions that could cause the effect. That is, in a completely dark room while viewing a dark background with bright objects or writing. The photo I've included is as close to what I see from the naked eye as possible. Keep in mind that photos can exaggerate the blooming effect when taken at a slower shutter speed so don't believe everything you see online.</p><p>Moving on to the benchmarks, we tested the screen twice: once with HDR and once playing non-HDR content. Our colorimeter registered 563 nits of brightness when showing non-HDR content, which puts it right around the iPad Pro 2020 (559 nits), and ahead of the Surface Pro 7+ (358 nits) and the Galaxy Tab S7 Plus (430 nits).</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:5873px;"><p class="vanilla-image-block" style="padding-top:66.52%;"><picture><source type="image/webp" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/gcSb7hbyrj8B6g4PVZHbtH.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop mag)</span></figcaption></figure><p>Switching to HDR content lets the mini-LED shine, literally. The iPad Pro's XR screen hit 1,582 nits when we looked at 10% of the screen that was illuminated. We expanded our view to 40% of the panel and measured 1,588 nits. When we tested the entire screen playing HDR content, it hit a blinding 1,251 nits.&nbsp;</p><p>Color coverage is also somewhat limited, showing how much punchier the Galaxy Tab S7 Plus' AMOLED panel looks compared to the iPad Pro's screen. The iPad Pro 2021 produces 115% of the DCI-P3 color gamut whereas the Surface Tab S7 Plus hit 211%. Surprisingly, the iPad Pro 2021 is less vivid than the iPad Pro 2020 (123%), though it tops the iPad Air (103%).</p><h2 id="ipad-pro-keyboard-xa0">iPad Pro keyboard&nbsp;</h2><p>There are two official iPad Pro keyboard covers and various third-party options.&nbsp;</p><p>Apple sent me the Magic Keyboard, which I've previously reviewed in full. This latest version is identical to the previous one apart from two changes. First, the Magic Keyboard now comes in white. It is a crisp, white hue that matches the Apple Pencil; the smooth finish feels nice, but is very slippery. Also, the white surface shows dirt and grime more than the black variant.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/RZiiRDcGsCk2AWrUsxwKmg.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>I kindly suggest reading my full <a href="https://www.laptopmag.com/reviews/magic-keyboard-for-ipad-pro-review">Magic Keyboard review</a>. The TL;DR version is that the backlit keys feel great to type on, and the floating design is clever and uses sturdy cantilevered hinges, but there are some major drawbacks. Chief among those is the weight (1.6 pounds), that you can't use the iPad Pro as a regular tablet without detaching it from the accessory, and the dizzying price of $349.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/yZfaFUkaQgRaTy2nLBXq3h.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>It is, however, a major upgrade from the $199 Smart Keyboard, which has shallow keys and lacks a touchpad, meaning you can't take advantage of all the cursor-friendly features Apple has added to iPadOS in the past year.</p><h2 id="ipad-pro-apple-pencil-2-xa0">iPad Pro Apple Pencil 2&nbsp;</h2><p>We didn't get a new stylus this year, but the Apple Pencil 2 is one of the better ones on the market. It is also one of the most expensive at $129, but artists, students, designers or anyone who prefers hand-written notes will get their money's worth.&nbsp;</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/88aS3ERqNtHkRMyf3R2QBh.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>The length and girth of the pen make it suitable for most hand sizes, and the weight is evenly balanced so the pen doesn't see-saw as you write. The one-sided flat edge reminds me of the legendary Lamy Safari fountain pen, which contours nicely to your grip.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1651px;"><p class="vanilla-image-block" style="padding-top:56.27%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/KtDPCqchSQrozbbwv6RCti.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>I can't begin to pose as an artist, but the pencil reacted quickly to my erratic swipes as I drew a <em>very </em>rough sketch of a flower. There was no perceivable latency and the pen supports tilt. Also, the double-tap feature on the touch-sensitive edge let me changing tools and switch to the eraser (something I did often) with ease.</p><p>I love how the pen magnetically attaches to the edge of the iPad Pro with a satisfying snap and immediately begins charging. The tablet alerts you when the stylus is properly placed though I had no issues finding the sweet spot. The pen feels sturdy on the edge, but because it uses a magnetic instead of a loop, it can get knocked off when slid into a bag or backpack.</p><h2 id="ipad-pro-audio-xa0">iPad Pro audio&nbsp;</h2><p>Four speakers are split evenly on the top and bottom edges of the iPad Pro and pack some serious sonic oomph. My wife and I had fun jamming out to LEISURE's "Take You Higher." The relaxing vocals were clear and present, and there was an airiness to the electronic instrumentals that sounded great as the soul-meets-pop band dished out funky grooves.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/SbxQNvc7bR2zPUHtwjZtqh.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>We couldn't help but bob our heads to Dayglow's retro bop "Close to you." The groovy electronic tones were crisp beneath the singer's smooth vocals while the softly thudding bass kept the frenetic rhythm. When the falsetto chorus sets in, the tablet did a good job of keeping the treble tones sounding crisp without them becoming peaky or sharp. Yes, the speakers lack depth and can sound digitized when too many noises enter the soundstage, but as far as tablet speakers go, these are some of the best.&nbsp;</p><h2 id="ipad-pro-performance-xa0">iPad Pro performance&nbsp;</h2><p>iPad Pro, meet the M1. Using the same chip found in the entry-level <a href="https://www.laptopmag.com/apple-macbook-pro-13-inch-m1">MacBook Pro</a> and <a href="https://www.laptopmag.com/reviews/macbook-air-m1-2020">MacBook Air</a>, the 2021 iPad Pro takes the fastest tablet on the market and pumps it with rocket fuel. It is fast to the point where I wouldn't know where to begin in my trials to push the iPad Pro to its computing limits. I'd be surprised if any iPad Pro owner found the performance ceiling of this slate unless you run demanding programs typically meant for laptops or desktops.&nbsp;</p><p>For most users, the M1 chip means everything will run slightly faster and smoother than before. Apps opened instantly, websites blinked onto the screen, and navigating the OS was a silky, delay-free joy.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/FjBwC9czAQhkAKM5NeNxdi.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>I fired up Civilization VI, a notoriously intensive game. The tutorial ran great. Load screens never lingered too long and animations were buttery; within minutes, I was training warriors to protect my city and started researching mining to advance our technologies. I then downloaded Adobe Lightroom, an excellent free photo editing app, and did some minor editing. Again, the iPad Pro held its ground, allowing me to adjust lighting, contrast, and crop without skipping a beat.&nbsp;</p><p>On the Geekbench 5 overall performance test, the iPad Pro scored a 7,298, crushing the iPad Air (4,262, A14 Bionic), the previous iPad Pro (4,720, A12Z) as well as anything released by the competition including the Surface Pro 7+ (4,825, Core i5-1135G7) and the Samsung Galaxy Tab S7 Plus (Snapdragon 865+, 2,910).</p><p>When we ran the Adobe Premiere Rush test, the iPad Pro with its M1 chip took 22 seconds to add a color filter and transition to a 4K video before exporting it to 1080p resolution. The previous model needed 22 seconds and the iPad Air clocked in at 27 seconds.</p><h2 id="ipad-pro-5g-xa0">iPad Pro 5G&nbsp;</h2><p>New to the iPad Pro is 5G support. In the US, that means both high-speed mmWave 5G and sub-6Ghz 5G for the widest coverage across multiple carriers including Verizon, T-Mobile, and AT&amp;T. Apple depicts the flavor of 5G you're receiving with a specific icon in the status bar. If you're in an area with the latest wireless standard, you'll either see a 5G, 5G+ or 5G UW icon (in order of slowest to fastest speeds) in the top-right corner.&nbsp;</p><p>Apple sent me a 5G Verizon SIM card so I could test the speeds in Austin, Texas, one of the few markets with good 5G coverage. Unfortunately, I only get the standard 5G, not the blink-and-you-miss-it Ultra-Wideband (5G UW) variant. Also, the reception in my apartment was poor, so the iPad kept fluctuating between 5G and 4G LTE. Average download speeds were a modest 10Mbps.</p><h2 id="ipad-pro-battery-life-xa0">iPad Pro battery life&nbsp;</h2><p>New display technology, so what? The 12.9-inch iPad Pro has great battery life, lasting 10 hours and 48 minutes on the Laptop Mag battery test, which involves continuous web browsing over Wi-Fi at 150 nits.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/jVKrErf7qAjRB6urVj3Z4j.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>The iPad Pro won't break any endurance records, but all-day battery life for a slate with a large, first-of-its-kind display is impressive. It even lasts longer on a charge than the previous model (10:16), the iPad Air 2020 (10:29) and the Galaxy Tab S7 Plus (8:51) with its AMOLED panel. The Surface Pro 7+ (8:49) lags behind its competitors in this area.&nbsp;</p><p>I wish the iPad Pro was quicker to charge. After 15 minutes on the included USB-C charger, the tablet reached only 10% and 19% after 30 minutes.</p><h2 id="ipados">iPadOS</h2><p>The iPad Pro is more like the MacBook Air or MacBook Pro than ever before, now that it runs on the M1 chip and flaunts the mini-LED panel expected to arrive in Apple's next batch of laptops. Also, Apple debuted touchpad and keyboard support on the previous iPad Pro, bringing its tablet closer to a tablet-laptop hybrid like the Surface Pro. And yet, Apple continues to say that it will never merge its operating systems.&nbsp;</p><p>In its current state, iPadOS is limited given the power under the hood of this latest tablet. You can multitask by using Split View or Slide Over: two ways to get multiple windows open at once. Both use the gesture system Apple built specifically for the iPad, but operating multiple apps or browsers at once just isn't as intuitive as using split-screen on a laptop or desktop. Moreover, iPadOS is still missing several pro-level apps, like Apple's own Final Cut Pro. Apple could bring the iPad Pro closer to parity with Macs when iPadOS 15 arrives &mdash; &nbsp;until then, this tablet works best as a tablet, not a MacBook replacement.&nbsp;</p><h2 id="ipad-pro-cameras-xa0">iPad Pro cameras&nbsp;</h2><p>Apple pulled a rabbit out of the hat this year with the addition of Center Stage, a face-tracking feature that ensures you stay centered within the frame during video calls. Like a true magician, Apple doesn't give away its tricks (hint: it uses machine learning) but trust me, the magic is real.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:1152px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/wY2y6rJ3bR5FpW5XUuBLvN-320-80.gif 320w, https://cdn.mos.cms.futurecdn.net/wY2y6rJ3bR5FpW5XUuBLvN-650-80.gif 650w, https://cdn.mos.cms.futurecdn.net/wY2y6rJ3bR5FpW5XUuBLvN-970-80.gif 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/wY2y6rJ3bR5FpW5XUuBLvN.gif" data-pin-media="https://cdn.mos.cms.futurecdn.net/wY2y6rJ3bR5FpW5XUuBLvN.gif"></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>As if it were mounted to a gimbal, the new 12MP, f/1.8 front-facing camera smoothly tracked my movements as I weaved to the left or right and bobbed above and below the camera's field of view. It felt as if someone were expertly operating the camera on a tripod while smoothly zooming in and out to ensure my frame stayed within the shot. The only hangup is when you're intentionally moving out of the shot or if someone nearby &mdash; &nbsp;like a kiddo or your spouse &mdash; &nbsp;is hiding from view.&nbsp;</p><p>It's odd that the lens is located on the narrow end of the iPad Pro. When docked to the Magic Keyboard, the camera looks at you from the side instead of straight-on which makes it seem like you aren't looking in the wrong direction during video calls.&nbsp;</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/L5wyCChUSHkBZDf4QSwupf.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>If you aren't embarrassed about hoisting a large metal slab to take photos, then you'll enjoy excellent image quality from the familiar 12-megapixel, f/1.8 wide-angle lens and the secondary 10MP, f/2.4 ultra-wide-angle camera on the back of the iPad Pro. The photos don't compare to what you get from the iPhone 12 or <a href="https://www.laptopmag.com/reviews/iphone-12-pro">iPhone 12 Pro</a>, but then again, who is asking for DSLR-quality photos from a tablet?</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:4032px;"><p class="vanilla-image-block" style="padding-top:75.00%;"><picture><source type="image/webp" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-320-80.jpeg.webp 320w, https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-650-80.jpeg.webp 650w, https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-970-80.jpeg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa.jpeg" data-pin-media="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa.jpeg"></source><source type="image/jpeg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-320-80.jpeg 320w, https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-650-80.jpeg 650w, https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-970-80.jpeg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa.jpeg" data-pin-media="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa.jpeg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-320-80.jpeg 320w, https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-650-80.jpeg 650w, https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa-970-80.jpeg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa.jpeg" data-pin-media="https://cdn.mos.cms.futurecdn.net/LX8BQSk6YRAeHV2Su752sa.jpeg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>This photo of a snake plant is detailed and the pot is the perfect salmon hue. But look closely and you'll see that the contrast has been pushed so the depth of the blacks seems to over-sharpen the edges. You also wouldn't want to overcrop or blow this image up because the sharpness degrades quickly as you zoom in.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:4032px;"><p class="vanilla-image-block" style="padding-top:75.00%;"><picture><source type="image/webp" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-320-80.jpeg.webp 320w, https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-650-80.jpeg.webp 650w, https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-970-80.jpeg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ.jpeg" data-pin-media="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ.jpeg"></source><source type="image/jpeg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-320-80.jpeg 320w, https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-650-80.jpeg 650w, https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-970-80.jpeg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ.jpeg" data-pin-media="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ.jpeg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021" class="expandable lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-320-80.jpeg 320w, https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-650-80.jpeg 650w, https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ-970-80.jpeg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ.jpeg" data-pin-media="https://cdn.mos.cms.futurecdn.net/V4ihaWDoUENjZ5bfoprejZ.jpeg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>I actually prefer this still life I took in my office despite the poor lighting conditions. You can clearly read the "Citrus Lavender" scent of the candle (and even the description below!) and see the stitching in the cute orange fish. Again, the colors are all spot-on.&nbsp;</p><p>Excuse <a href="https://cdn.mos.cms.futurecdn.net/9mAy3cfjp9Eh9SkPSTrNHY.jpeg" data-url="https://cdn.mos.cms.futurecdn.net/9mAy3cfjp9Eh9SkPSTrNHY.jpeg">this selfie</a> taken with the upgraded 12MP f/1.8 front-facing camera; I didn't think it would reveal enough detail to oust my poor pandemic-era shaving habits. Loose beard hairs are visibly fraying in every direction and the lens was sharp enough to capture skin pores. The colors are also great; you can see the soft yellow lines in my striped shirt and my rosy complexion from playing tennis under the Texas sun.</p><h2 id="bottom-line-xa0">Bottom line&nbsp;</h2><p>The iPad Pro 2021 is the most premium tablet you can buy, bringing significant hardware upgrades to Apple's most expensive slate. And yet, the user experience doesn't feel much different from the previous model. The Liquid Retina XDR display is fantastic, but the benefits over the previous display are limited when you aren't watching HDR content.</p><figure data-bordeaux-image-check><div class="image-full-width-wrapper"><div class="image-widthsetter" style="max-width:2000px;"><p class="vanilla-image-block" style="padding-top:56.25%;"><picture><source type="image/webp" alt="iPad Pro 2021 (12.9-inch)" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-650-80.jpg.webp 650w, https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-970-80.jpg.webp 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg.jpg"></source><source type="image/jpeg" alt="iPad Pro 2021 (12.9-inch)" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg.jpg"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="iPad Pro 2021 (12.9-inch)" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="(min-width: 1000px) 970px, calc(100vw - 40px)" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-650-80.jpg 650w, https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg-970-80.jpg 970w" data-original-mos="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/EQaNvVKkkdAMsFFmSC52Kg.jpg"></picture></p></div></div><figcaption itemprop="caption description"><span class="credit" itemprop="copyrightHolder">(Image credit: Laptop Mag)</span></figcaption></figure><p>The M1 chip offers a welcome performance bump, but the iPad Pro always had excess power when you consider the limitations of its OS and form factor. So where does that leave us? Well, the iPad Pro 2021 is a solid upgrade over the previous model, even if the benefits, including 5G support, aren't always apparent. As expensive as it may be ($1,099 starting), it's hard to criticize Apple for bringing so many upgrades while only bumping up the price by $100.&nbsp;</p><p>What you're probably wondering is whether it makes sense for you to spend four figures on a tablet, when you could buy an iPad Air for $599 or a MacBook Pro for about as much as the iPad Pro. My answer to most people is an emphatic "no." If you want a premium tablet and a smaller screen isn't a deal-breaker, save your money and get the iPad Air which shares the most important features with its pricier sibling.&nbsp;</p><p>The iPad Pro 2021 is for the same crowd as the previous models: those without a budget who want the absolute best tablet on the market, as well as professionals and enthusiasts using intensive apps for content creation or editing. Unless Apple changes direction and turns the iPad Pro into a true laptop replacement, the market for this tablet will remain limited.&nbsp;</p><aside class="hawk-placeholder" data-model-name="iPad_Pro_2021" data-name="BOT widget" data-render-type="fte" data-show-toggle="1" data-skip="editorial" data-widget-type="review"></aside>
<div class="onesignal-customlink-container"></div>
</div>
<div id="this-will-be-used-for-mpu-2"></div>
<div class="read-more-container"></div>
</section>
<div class="xenforo-comments-see-all">
</div>
<div class="related-articles-block">
<div class="related-articles-wrap">
<div id="expanding-articles"></div>
</div> </div>
<footer id="comment-jump">
</footer>
</div>
</article>
<aside id="sidebar">
<div id="sidebar-top" class="ad-unit"></div>
<section class="box newsletter-signup">
<div class="separator-heading">
<span>
<i class="icon icon-envelope white">
<svg class="icon-image" height="24" viewbox="0 0 24 24" width="24" xmlns="http://www.w3.org/2000/svg"><path d="m20.487 20.487a12 12 0 0 1 -16.974-16.975 12 12 0 0 1 16.974 16.975z"></path><g fill="#fff"><path d="m4.41 15.943 4.316-4.843-4.316-3.237z"></path><path d="m9.877 11.987-4.483 5.059h13.139l-4.34-5.227-2.278 1.655z"></path><path d="m5.658 6.953 6.257 4.723 6.282-4.723z"></path><path d="m19.588 7.84-4.1 3.092 4.1 4.891z"></path></g></svg>
</i>
<span class="newsletter-title">Be In the Know</span>
</span>
</div>
<div class="grey-box">
<p>Get instant access to breaking news, the hottest reviews, great deals and helpful tips.</p>
<form class="emailform" method="GET" action="https://www.laptopmag.com/email-signup">
<div class="input__wrapper">
<input type="text" class="name__input" name="NAME" value>
<input type="email" class="mail__input" name="MAIL" value placeholder="Your Email Address" required>
</div>
<div class="emailform__checkbox-rows">
<div class="emailform__checkbox-row" data-newsletter-consent-type="default-market" id="emailform__consent-news-and-offers">
<label class="emailform__checkbox-row__label">
<input type="checkbox" id="emailform__consent-news-and-offers-yes" class="emailform__checkbox-row__checkbox" value="1" name="CONTACT_OTHER_BRANDS">
Contact me with news and offers from other Future brands
</label>
</div>
<div class="emailform__checkbox-row" data-newsletter-consent-type="default-market" id="emailform__consent-partners-and-sponsors">
<label class="emailform__checkbox-row__label">
<input type="checkbox" id="emailform__consent-partners-and-sponsors-yes" class="emailform__checkbox-row__checkbox" value="1" name="CONTACT_PARTNERS">
Receive email from us on behalf of our trusted partners or sponsors
</label>
</div>
</div>
<div class="submit__wrapper">
<input class="submit__button" type="submit" value="Sign me up">
</div>
<input type="hidden" class="hidden__id" name="ID" id="ID" value="PbkPj5hSTiI7DaHxA%2BxhNEnb2DC0sRfetMa8wX06DbF4AUl5zRkYymPQ7Wzu1%2BA6Sh5nStr7zk%2Bl5%2Bh9b8" data-newsletter-consent-type="default">
<input type="hidden" class="hidden__brand" name="BRAND" id="BRAND" value="LTP" data-newsletter-consent-type="default">
<input type="hidden" class="hidden__lang" name="LANG" id="LANG" value="EN" data-newsletter-consent-type="default">
<input type="hidden" class="hidden__source" name="SOURCE" id="SOURCE" value="2" data-newsletter-consent-type="default">
</form>
<div class="successmessage --hide-me">
<p>Thank you for signing up to Laptop Mag. You will receive a verification email shortly.</p>
</div>
<div class="failuremessage --hide-me">
<p>There was a problem. Please refresh the page and try again.</p>
</div>
<footer>
<small>No spam, we promise. You can unsubscribe at any time and we'll never share your details without your permission.</small>
</footer>
</div>
</section>
<div id="sidebar-popular-top" class="ad-unit"></div>
<section class="popular-box">
<div id="popular-box-wrapper" class="style1">
<div class="most-popular-tab-bar">
<input type="radio" name="popradio" id="popradio-1" checked>
<div id="popularcontent">
<div class="flex-row">
<label class="poplabel" id="poplabel-1" for="popradio-1">
<span>More from Laptop Mag...</span>
</label>
</div>
<ol class="popular-list active" id="poplist-1">
<li class="most-popular-item first-article">
<div style="width:100%">
<a href="https://www.laptopmag.com/features/every-ratchet-and-clank-game-ranked-from-worst-to-best" aria-label="Every Ratchet &amp; Clank game (including Rift Apart) ranked from worst to best">
<picture><source type="image/webp" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-450-80.jpg.webp 450w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-1024-80.jpg.webp 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh.jpg" data-pin-nopin="true"></source><source type="image/jpeg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh.jpg" data-pin-nopin="true"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/eLCMvqneCrMe2pc27H2gCh.jpg" data-pin-nopin="true"></picture>
</a>
<div class="popular-listings">
<span class="number-1">1</span><div class="listings-heading"><a href="https://www.laptopmag.com/features/every-ratchet-and-clank-game-ranked-from-worst-to-best">Every Ratchet &amp; Clank game (including Rift Apart) ranked from worst to best</a></div>
</div>
</div>
</li>
<li class="most-popular-item ">
<div style="width:100%">
<a href="https://www.laptopmag.com/deals/prime-day-laptop-deals" aria-label="Best Prime Day laptop deals 2021: Early sales on select PCs">
<picture><source type="image/webp" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-450-80.jpg.webp 450w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-1024-80.jpg.webp 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH.jpg" data-pin-nopin="true"></source><source type="image/jpeg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH.jpg" data-pin-nopin="true"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/TiyiqLE3S43BWki5SfwRzH.jpg" data-pin-nopin="true"></picture>
</a>
<div class="popular-listings">
<span class="number-2">2</span><div class="listings-heading"><a href="https://www.laptopmag.com/deals/prime-day-laptop-deals">Best Prime Day laptop deals 2021: Early sales on select PCs</a></div>
</div>
</div>
</li>
<li class="most-popular-item ">
<div style="width:100%">
<a href="https://www.laptopmag.com/news/amazon-prime-day-2021-date-deals" aria-label="Amazon Prime Day deals 2021: Sales preview">
<picture><source type="image/webp" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-450-80.jpg.webp 450w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-1024-80.jpg.webp 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC.jpg" data-pin-nopin="true"></source><source type="image/jpeg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC.jpg" data-pin-nopin="true"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/kP4WoNQFyspF5a8MeZrLtC.jpg" data-pin-nopin="true"></picture>
</a>
<div class="popular-listings">
<span class="number-3">3</span><div class="listings-heading"><a href="https://www.laptopmag.com/news/amazon-prime-day-2021-date-deals">Amazon Prime Day deals 2021: Sales preview</a></div>
</div>
</div>
</li>
<li class="most-popular-item ">
<div style="width:100%">
<a href="https://www.laptopmag.com/articles/best-laptops-under-1000" aria-label="The best laptops under $1,000 in 2021">
<picture><source type="image/webp" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-450-80.jpg.webp 450w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-1024-80.jpg.webp 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT.jpg" data-pin-nopin="true"></source><source type="image/jpeg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT.jpg" data-pin-nopin="true"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/9fbHKqVMEZM5tcZjct5GaT.jpg" data-pin-nopin="true"></picture>
</a>
<div class="popular-listings">
<span class="number-4">4</span><div class="listings-heading"><a href="https://www.laptopmag.com/articles/best-laptops-under-1000">The best laptops under $1,000 in 2021</a></div>
</div>
</div>
</li>
<li class="most-popular-item ">
<div style="width:100%">
<a href="https://www.laptopmag.com/news/best-anti-prime-day-deals-uk" aria-label="Best Anti-Prime Day deals in the UK">
<picture><source type="image/webp" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-320-80.jpg.webp 320w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-450-80.jpg.webp 450w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-970-80.jpg.webp 970w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-1024-80.jpg.webp 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H.jpg" data-pin-nopin="true"></source><source type="image/jpeg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H.jpg" data-pin-nopin="true"></source><img src="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" alt="" class=" lazy-image-van optional-image" onerror="if(this.src &amp;&amp; this.src.indexOf('missing-image.svg') !== -1){return true;};this.parentNode.replaceChild(window.missingImage(),this)" sizes="99vw" data-normal="https://vanilla.futurecdn.net/laptopmag/media/img/missing-image.svg" data-srcset="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-320-80.jpg 320w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-450-80.jpg 450w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-970-80.jpg 970w, https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H-1024-80.jpg 1024w" data-original-mos="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H.jpg" data-pin-media="https://cdn.mos.cms.futurecdn.net/AmbyYMfSxd2oziTfxoM36H.jpg" data-pin-nopin="true"></picture>
</a>
<div class="popular-listings">
<span class="number-5">5</span><div class="listings-heading"><a href="https://www.laptopmag.com/news/best-anti-prime-day-deals-uk">Best Anti-Prime Day deals in the UK</a></div>
</div>
</div>
</li>
</ol>
</div>
</div>
</div>
</section>
<div id="hawkMagWidget"></div>
<div id="sidebar-popular-bottom" class="ad-unit"></div>
</aside>
</div>
<script id="selligent-tag">
function selligent_initialiser() {
window.wa = document.createElement("script"),
wa_s = document.getElementsByTagName("script")[0];
window.wa.src = "https://targetemsecure.blob.core.windows.net/138526d1-8ff9-4de4-b84a-3a11ec020ede/138526d18ff94de4b84a3a11ec020ede_1.js";
window.wa.type = "text/javascript";
wa_s.parentNode.insertBefore(wa, wa_s);
window.wa.bt_queue = [];
window.wa.afterInit = function(){
window.wa.bt_queue.push({
"customIdentifier": "",
"async": true,
"isEvent": false,
"isTargeting": true,
"tagValues":[
{ "tag": "CATEGORY", "value": window.ffte.properties?.articleVertical || '' },
{ "tag": "VERTICAL_SUB_SECTION", "value": window.ffte.properties?.articleCategoryHandle.join() || '' },
{ "tag": "TAGS", "value": window.ffte.properties?.articleTagHandle.join() || '' },
{ "tag": "FEP_PRODUCTS", "value": [window.fepPrimaryProduct, window.fepSecondaryProducts].join() }
],
"exposedFields": [
{ "field": "Number_of_hits_in_the_last_day" },
{ "field": "Average_time__minutes__per_visit" }
]
});
}
}
window.vanilla.featureFlags.selligent.enabled && window.reliablePageLoad.then(function(){
reliableConsentGiven.then(function (consentResponse) {
if (consentResponse.consent && consentResponse.consent.gdprApplies) {
__tcfapi('getNonIABVendorConsents', 2, function (consent, success) {
// Selligent's id = 1
// Purposes for selligent = 5, 6, 8, 10
var purposes = consentResponse.consent.purpose.consents;
var relevantPurposes = [purposes[5], purposes[6], purposes[8], purposes[10]];
var consentForPurposes = relevantPurposes.every((purpose) => purpose);
if (consent.nonIabVendorConsents[1] && consentForPurposes){
selligent_initialiser();
}
});
}
});
ccpaAppliesPromise.then(function (ccpaApplies) {
if (ccpaApplies) {
selligent_initialiser();
}
});
});
</script>
<script type="module" id="hawklinks-script-es6" async src="https://hawk.laptopmag.com/hl/es6/hawklinks.js"></script>
<script type="nomodule" id="hawklinks-script" async src="https://hawk.laptopmag.com/hl/es5/hawklinks.js"></script>
<script>
window.falconConfigs = [];
window.Falcon = window.Falcon || {
mount: function(configs) {
falconConfigs.push(...configs);
},
};
window.reliableDOMContentLoaded.then(function() {
window.Falcon.mount([
{
selector: '.falcon-placeholder',
},
]);
});
</script>
<meta property="article:published_time" content="2021-06-15T22:00:49Z">
<meta property="article:modified_time" content="2021-06-15T22:00:49.238Z">
<footer id="document-footer" class="container full">
<div id="document-footer-content">
<p>Laptop Mag is part of Future US Inc, an international media group and leading digital publisher. <a href="http://www.futureplc.com" target="_blank">Visit our corporate site</a>.</p>
<nav>
<ul>
<li><a href="http://www.futureplc.com/terms-conditions/" target="_blank">Terms and conditions</a></li>
<li><a href="http://www.futureplc.com/privacy-policy/" target="_blank">Privacy policy</a></li>
<li><a href="http://www.futureplc.com/cookies-policy/" target="_blank">Cookies policy</a></li>
<li><a href="https://www.futureplc.com/accessibility-statement/">Accessibility Statement</a></li>
<li><a href="https://www.laptopmag.com/articles/about-us" target="_blank">About us</a></li>
<li><a href="https://www.laptopmag.com/archive" target="_blank">Archive</a></li>
</ul>
</nav>
<p>©
Future US, Inc. 11 West 42nd Street, 15th Floor,
New York,
NY 10036. </p>
</div>
</footer>
<script>
window.vanL10N = null;
</script> <!-- Begin comScore Tag -->
<script>
function comscoreIntegration() {
var TIMEOUT_DELAY = 2000;
var COMSCORE_ID = "10055482";
function callComscore(ucfrValue) {
window._comscore = window._comscore || [];
var comscorePayload = {
c1: "2",
c2: COMSCORE_ID,
};
if(ucfrValue) {
comscorePayload.cs_ucfr = ucfrValue;
}
window._comscore.push(comscorePayload);
var s = document.createElement('script'), el = document.getElementsByTagName("script")[0];
s.async = true;
var URLbeginning = document.location.protocol == "https:" ? "https://sb" : "http://b";
if (window.__tcfapi) {
s.src = URLbeginning + '.scorecardresearch.com/cs/' + COMSCORE_ID + '/beacon.js';
} else {
s.src = URLbeginning + '.scorecardresearch.com/beacon.js';
}
el.parentNode.insertBefore(s, el);
}
if (window.__tcfapi) {
var timeout = window.setTimeout(function() {
callComscore();
}, TIMEOUT_DELAY);
window.__tcfapi('addEventListener', 2, function(res) {
window.__tcfapi('removeEventListener', 2, function() {}, res.listenerId);
const validStatus = ['tcloaded', 'useractioncomplete'];
if (validStatus.includes(res.eventStatus) && res.gdprApplies) {
window.clearTimeout(timeout);
callComscore(res.vendor?.consents?.[77] ? 1 : 0);
}
});
} else {
callComscore();
};
}
comscoreIntegration();
</script>
<!-- End comScore Tag -->
<script>
var dfp_config = {
"ad_unit": "10518929/Laptop_Mag/",
"live_ad_unit": "10518929/Laptop_Mag/",
"test_ad_unit": "10518929/Laptop_Mag_Test/",
"recovery_ad_unit": "",
"recovery_test_ad_unit": "",
"site_platform": "vanilla",
"keywords": "type_review,channel_tablets,awardeditorschoice,serversidehawk,ipad pro 12.9-inch,iPad Pro,Apple,iPad Pro (2021)",
"article_id": "H98JCEZtvf3Udyt82RtYNG",
"vanilla_article_id": "H98JCEZtvf3Udyt82RtYNG",
"page_type": "review",
"product_brand": "null",
"product_category": "",
"product": "iPad Pro (2021)",
"vertical": "",
"source": "",
"provertical": "",
"jwplayer": "carousel"
}
</script>
<script>
dfp_config.gallery_refresh_interval = 2;
</script>
<script>window.vanillaComponents=[{"parentIdentifier":"#article-body","targetIdentifier":".fwd-link","eventType":"click","action":"Click on Forward Linker","elementName":"Forward Linker","addMoreInfo":false},{"parentIdentifier":"#article-body","targetIdentifier":"a","excludeTargetClass":"fwd-link","eventType":"click","action":"Click on Inline Link","elementName":"Inline Link","addMoreInfo":false},{"parentIdentifier":".pagination-numerical-list","targetIdentifier":".pagination-numerical-list-item a","eventType":"click","action":"Click on Article Pagination","elementName":"Article Pagination Number","addMoreInfo":true},{"parentIdentifier":".navigation-sequential","targetIdentifier":".prev,.next","eventType":"click","action":"Click on Article Pagination","elementName":"Article Pagination Prev\/Next","addMoreInfo":true},{"parentIdentifier":".socialite-widget","targetIdentifier":"a","eventType":"click","action":"Click on Article Social","elementName":"Article Social","addMoreInfo":true},{"parentIdentifier":"#articleTag","targetIdentifier":".tag a","eventType":"click","action":"Click on Article Tag","elementName":"Article Tag","addMoreInfo":false},{"parentIdentifier":".author-block-social-nav","targetIdentifier":"a","eventType":"click","action":"Click on Author Social","elementName":"Author Social","addMoreInfo":true},{"parentIdentifier":"#article-body","targetIdentifier":"a[data-event-label=elkInjectedRelatedBlock]","eventType":"click","action":"Click on ELK Injected Related Block","elementName":"ELK Injected Related Block","addMoreInfo":false},{"parentIdentifier":".newsletter-signup","targetIdentifier":".emailform","eventType":"visible","action":"Email sign-up sidebar is visible","elementName":"SIGNUP - Side Bar","addMoreInfo":false},{"parentIdentifier":".hawk-pre-order-main-container","targetIdentifier":".hawk-pre-order-form-container","eventType":"visible","action":"Hawk Widget is visible","elementName":"HAWK WIDGET","addMoreInfo":false},{"parentIdentifier":".list-text-links-trending-panel","targetIdentifier":".listingResult a","eventType":"click","action":"Click on News","elementName":"News Article","addMoreInfo":false},{"parentIdentifier":".menuitems","targetIdentifier":".menu-item a","eventType":"click","action":"Click on Nav Item","elementName":"Nav Item","addMoreInfo":true},{"parentIdentifier":".menuitems","targetIdentifier":".menu-item-more","eventType":"hover","action":"Hover on Nav Item","elementName":"Nav Item","addMoreInfo":true},{"targetIdentifier":".burgerbar .menu-hamburger","eventType":"click","action":"Click on Mobile Hamburger","elementName":"Mobile Hamburger","addMoreInfo":false},{"parentIdentifier":".burgerbar","targetIdentifier":".buttons-social a","eventType":"click","action":"Click on Nav Social","elementName":"Nav Social","addMoreInfo":true},{"targetIdentifier":"#club-login > div","eventType":"hover","action":"Hover on PC Gamer Club","elementName":"PC Gamer Club","addMoreInfo":false},{"parentIdentifier":"#club-login","targetIdentifier":"a","eventType":"click","action":"Click on PC Gamer Club Login\/Register","elementName":"PC Gamer Club Login\/Register","addMoreInfo":false},{"parentIdentifier":".recommendation-articles","targetIdentifier":".recommended-article a","eventType":"click","action":"Click on Recommended Article","elementName":"Recommended Article","addMoreInfo":false},{"targetIdentifier":".burgerbar .button-search","eventType":"click","action":"Click on Search","elementName":"Search","addMoreInfo":false},{"targetIdentifier":".burgerbar form.search-box","eventType":"submit","action":"Submit Search","elementName":"Search","addMoreInfo":false},{"targetIdentifier":".logo > a","eventType":"click","action":"Click on Site Logo","elementName":"Site Logo","addMoreInfo":false},{"parentIdentifier":".top-featured","targetIdentifier":".feature-block-item-wrapper a","eventType":"click","action":"Click on Featured Article","elementName":"Featured Article","addMoreInfo":false},{"parentIdentifier":".trending-items","targetIdentifier":".trending-item a","eventType":"click","action":"Click on Trending Bar Item","elementName":"Trending Bar Item","addMoreInfo":false},{"parentIdentifier":".trending-bar","targetIdentifier":".brand-items a","eventType":"click","action":"Click on Trending Bar - Brand Link","elementName":"Trending Bar - Brand Link","addMoreInfo":false},{"parentIdentifier":".locale-selector__dropdown__continents","targetIdentifier":".locale-selector__option","eventType":"click","action":"Click on Locale Flag","elementName":"Locale Flag","addMoreInfo":true},{"parentIdentifier":".locale-selector","targetIdentifier":".locale-selector__trigger","eventType":"click","action":"Click on Locale Flags Dropdown","elementName":"Locale Flags Dropdown","addMoreInfo":false}];</script>
<script>
var require = {waitSeconds:0};
</script>
<!-- Google Tag Manager -->
<script>
(function(){
function loadGTM(gtmCode){
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.defer=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer', gtmCode);
}
// Can't be in asset loader until we can call custom loader functions
;(window.Promise
? Promise.all([
window.reliablePageLoad,
window.reliableConsentGiven
])
: window.reliableConsentGiven
).then(function(){
setTimeout(
function(){
window.vanilla.featureFlags.gtm.sitespecific && loadGTM('GTM-WKJ4BVH')
window.vanilla.featureFlags.gtm.vanilla && loadGTM('GTM-KHCPGDF')
}, 1500);
});
})();
</script>
<!-- End Google Tag Manager -->
<script type="text/javascript">
(function(){
if(typeof window._taboola !== 'undefined'
&& typeof taboola_lists !== 'undefined'
&& Array.isArray(taboola_lists)
&& taboola_lists.length)
{
function loadTaboola()
{
!function (e, f, u) {
e.async = 1;
e.src = u;
f.parentNode.insertBefore(e, f);
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/futureplc-network/loader.js');
_taboola.push({article: 'auto'});
_taboola.push({flush: true});
}
// Can't be in asset loader until we can call custom loader functions
(window.Promise
? Promise.all([window.reliablePageLoad, window.reliableConsentGiven])
: window.reliableConsentGiven
).then(function(){
var taboolaDelay = window.location.host.indexOf('itproportal') > -1 ? 0 : 6000;
setTimeout(loadTaboola, taboolaDelay);
});
}
})();
</script>
<script>window.addEventListener("load",function(){if(!window.askForConsent){var e=document.createElement("script");e.src="https://vanilla.futurecdn.net/laptopmag/cookieconsent.min.js",e.onload=function(){var e=window.innerWidth>=700?"bottom":"top";window.cookieconsent.initialise({palette:{popup:{background:"#000"},button:{background:"#666666"}},position:e,content:{message:"We use cookies on this website to deliver content to you, personalise content and ads, provide social media features, and analyse our traffic. Click 'I accept' to consent to the use of cookies. More information on cookies and how to manage them",link:"click here",href:"http://www.futureplc.com/cookies-policy/",dismiss:"I accept"}})},document.body.appendChild(e);var o=document.createElement("link");o.rel="stylesheet",o.type="text/css",o.href="https://vanilla.futurecdn.net/laptopmag/cookieconsent.min.css",document.body.appendChild(o);var t=document.createElement("style");t.appendChild(document.createTextNode(".cc-window {z-index:10000000}")),document.body.appendChild(t)}});</script>
<!-- document assets - added by the article itself -->
<script>
window.vanilla.addJs({"id":"main-js","src":"\/\/vanilla.futurecdn.net\/laptopmag\/296797\/media\/shared\/js\/main.9b28108de37dacd40e1f.bundle.js"}, null, 0)
window.vanilla.addJs({"id":"ffte-js","src":"\/\/vanilla.futurecdn.net\/laptopmag\/296797\/media\/shared\/js\/app.js"}, 2000, 1)
window.vanilla.addCss({"href":"\/\/vanilla.futurecdn.net\/laptopmag\/296797\/media\/css\/laptopmag.min.css"})
</script> <script>
window.ffte = {"site":"laptopmag","endpoint":"\/\/api.vanilla.futurecdn.net\/article","locale":"US","lang":"en-us","gaCode":"UA-72111741-6","debug":[],"serverEnvironment":"live","staticHost":"vanilla.futurecdn.net\/laptopmag","regionLink":"","isGlobal":false,"platform":"responsive","isKube":true,"l10ns":"{\"\":{\"US\":{\"name\":\"US\",\"locale\":\"US\",\"link\":\"\",\"aliasOf\":\"US\",\"visitingFrom\":\"the US\",\"editionName\":\"US\",\"global\":false,\"hideFlag\":false,\"isDefault\":true,\"displayLabel\":\"US Edition\"},\"CA\":{\"name\":\"Canada\",\"locale\":\"CA\",\"link\":\"\",\"aliasOf\":\"US\",\"visitingFrom\":\"Canada\",\"editionName\":\"Canadian\",\"global\":false,\"hideFlag\":false,\"isDefault\":false,\"displayLabel\":\"CA Edition\"},\"GB\":{\"name\":\"UK\",\"locale\":\"GB\",\"link\":\"\\\/uk\",\"aliasOf\":\"GB\",\"visitingFrom\":\"the UK\",\"editionName\":\"UK\",\"global\":false,\"hideFlag\":false,\"isDefault\":false,\"displayLabel\":\"UK Edition\"},\"AU\":{\"name\":\"Australia\",\"locale\":\"AU\",\"link\":\"\\\/au\",\"aliasOf\":\"AU\",\"visitingFrom\":\"Australia\",\"editionName\":\"Australian\",\"global\":false,\"hideFlag\":false,\"isDefault\":false,\"displayLabel\":\"AU Edition\"}}}","properties":{"articleProduct":["iPad Pro (2021)"],"articleProductHandle":["ipad-pro-2021"],"articleType":"review","articleTemplate":"review","articleTagHandle":["ipad-pro-12-9-inch","ipad-pro","apple","ipad-pro-2021"],"articleTagType":["freeform","freeform","freeform","product"],"articleControlTag":["type_review","channel_tablets","awardeditorschoice","serversidehawk"],"articleVerticalHandle":[],"articleCategoryHandle":["tablets","ipad-pro"],"subSite":"","articleVertical":"","id":"H98JCEZtvf3Udyt82RtYNG","legacyId":"H98JCEZtvf3Udyt82RtYNG"}}
</script>
<script id="vanilla-slice-utils">!function(e){var n={};function r(t){if(n[t])return n[t].exports;var o=n[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,r),o.l=!0,o.exports}r.m=e,r.c=n,r.d=function(e,n,t){r.o(e,n)||Object.defineProperty(e,n,{enumerable:!0,get:t})},r.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},r.t=function(e,n){if(1&n&&(e=r(e)),8&n)return e;if(4&n&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(r.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&n&&"string"!=typeof e)for(var o in e)r.d(t,o,function(n){return e[n]}.bind(null,o));return t},r.n=function(e){var n=e&&e.__esModule?function(){return e.default}:function(){return e};return r.d(n,"a",n),n},r.o=function(e,n){return Object.prototype.hasOwnProperty.call(e,n)},r.p="",r(r.s=2)}([function(e,n){e.exports=function(e,n,r){return n in e?Object.defineProperty(e,n,{value:r,enumerable:!0,configurable:!0,writable:!0}):e[n]=r,e}},function(e,n,r){var t=r(4),o=r(5),i=r(6);e.exports=function(e){return t(e)||o(e)||i()}},function(e,n,r){e.exports=r(3)},function(e,n,r){"use strict";r.r(n);var t=r(0),o=r.n(t),i=r(1),c=r.n(i);function u(e,n){var r=Object.keys(e);if(Object.getOwnPropertySymbols){var t=Object.getOwnPropertySymbols(e);n&&(t=t.filter((function(n){return Object.getOwnPropertyDescriptor(e,n).enumerable}))),r.push.apply(r,t)}return r}function f(e){for(var n=1;n<arguments.length;n++){var r=null!=arguments[n]?arguments[n]:{};n%2?u(Object(r),!0).forEach((function(n){o()(e,n,r[n])})):Object.getOwnPropertyDescriptors?Object.defineProperties(e,Object.getOwnPropertyDescriptors(r)):u(Object(r)).forEach((function(n){Object.defineProperty(e,n,Object.getOwnPropertyDescriptor(r,n))}))}return e}var a=function(e,n){return Promise.all(e.map((function(e){var r=e.endpoint,t=e.windowObject,o=e.fallback;if(window.slice[t])return Promise.resolve();return function e(){var t=arguments.length>0&&void 0!==arguments[0]?arguments[0]:"".concat(n||"","/").concat(r);return new Promise((function(n,r){var i=document.createElement("script");i.async=!0,i.onload=n,i.onerror=function(){o.length?(Promise.all(c()(o).map((function(n){var r=n.window,t=n.src;return window[r]?(window.slice[r]=window[r],Promise.resolve()):e(t).then((function(){return window.slice[r]=window[r]}))}))).then((function(){n()})),o=[]):r()},i.src=t,document.body.appendChild(i)}))}()})))};window.slice=f(f({},window.slice||{}),{},{resolveDependencies:a}),n.default=a},function(e,n){e.exports=function(e){if(Array.isArray(e)){for(var n=0,r=new Array(e.length);n<e.length;n++)r[n]=e[n];return r}}},function(e,n){e.exports=function(e){if(Symbol.iterator in Object(e)||"[object Arguments]"===Object.prototype.toString.call(e))return Array.from(e)}},function(e,n){e.exports=function(){throw new TypeError("Invalid attempt to spread non-iterable instance")}}]);</script>
<script>
window.slice = window.slice || {}
// window.slice.hostname = 'https://slice.vanilla.futurecdn.net/'
window.slice.hostname = "https:\/\/slice.vanilla.futurecdn.net\/0-6-23\/";
</script>
<script id="vanilla-slice-components" type="text/javascript">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</script>
<script id="vanilla-slice-hydrate" type="text/javascript">
window.reliableDOMContentLoaded.then(function() {
var lsContainer = document.querySelector('.locale-selector-slice.slice-container');
var localeSelectorData = window.vanillaSlice.data.localeSelector;
var lsComponent = window.vanillaSlice.components.localeSelector;
lsComponent.hydrate(localeSelectorData, lsContainer);
});
</script>
<script>
window.vanilla.featureFlags.parsely.enabled && window.vanilla.addScript("//cdn.parsely.com/keys/laptopmag.com/p.js", 'parsely-cfg');
</script>
<script>
window.xkeys = ["laptopmag-platform-responsive","laptopmag-article-H98JCEZtvf3Udyt82RtYNG","laptopmag-articletype-review","laptopmag-articletemplate-review","laptopmag-article-age-recent","laptopmag-region-US","laptopmag-language-en","laptopmag-author-ySrPvEPQ2uCZKwHfb3myx4","laptopmag-tag-FWR98pWUrefCXFDfrepnL","laptopmag-tag-4tdPmKMu4JuCK2wcb69m7J","laptopmag-tag-8Qt7n2h5ndpjWgRYgWDcH4","laptopmag-tag-RHNJGPs6EWywAMFvETzAok","laptopmag-tag-feVUiDFRBGkxFyyZVnzKfJ"];
window.templateVariables = {};
</script>
</body>
<script>
window.ftr_request_id = "";
</script> </html>
