Skip to main content

Microsoft Edge bug wrecks YouTube when Adblock is enabled

(Image credit: Future)

Microsoft's new Edge had a successful launch, needing a few months to become the second most popular browser behind only Chrome. But now it has hit an early road bump that might convince people to stay with Chrome or move back to Firefox. 

Microsoft acknowledged a bug in Edge that is causing YouTube to fail when an adblocker extension is enabled. 

"We’ve heard that a number of users who have the AdBlock (Plus) or Adblock for Youtube extensions installed are running into errors on YouTube videos," Fawkes Serafinski, a product and community manager on Edge wrote in a post. "If you’re experiencing this bug, you will likely encounter a black screen on the video player when attempting to load a video on YouTube."

Microsoft recommends disabling the Adblock extension and reloading the YouTube page as a workaround until it can release a patch. This, of course, means you'll need to patiently watch one of those pesky 15-second ads before you can enjoy your video (if you're not subscribed to YouTube Premium). 

The company is asking users to send feedback if they encounter a similar problem, especially if the extension is disabled. You can do so by pressing the Shift+Alt+I keys and writing in any problems you faced. You can also press the ellipsis (...) menu and select Help and feedback.

It's not clear how widespread these problems are but they don't seem to be affecting every user; I didn't get an error while blocking YouTube ads in Edge using the Adblocker Plus extension. If you're one of the unlucky ones, then you'll need to wait for an update to arrive with a patch for the error.